<!DOCTYPE html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7 ie" lang="en"> <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8 ie7" lang="en"> <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9 ie8" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html xmlns="http://www.w3.org/1999/xhtml" lang="en-US"> <!--<![endif]-->

<head profile="http://gmpg.org/xfn/11">
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
	<title>Volunteers help maintain Sowers Cemetery  |  Rambler Newspapers | Serving Irving, Las Colinas, Valley Ranch, Coppell and DFW International Airport</title>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-67226227-1', 'auto');
  ga('send', 'pageview');

</script>
  <!--[if IE]>
    <script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script>
  <![endif]-->


	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="robots" content="index, nofollow" />
<meta name="description" content="Photo: Volunteers clear trees and brush at the century-old Sowers Cemetery. /Photo by John Starkey Volunteers arrived at Sowers Cemetery in Irving on Saturday morning, Feb. 4, to clean and ..." />
<meta name="keywords" content="community events,featured stories,irving" />
		
		<meta property="og:title" content="Volunteers help maintain Sowers Cemetery" />
	<meta property="og:type" content="article" />
	<meta property="og:url" content="http://ramblernewspapers.com/2017/03/volunteers-help-maintain-sowers-cemetery/" />
	        <meta property="og:image" content="http://ramblernewspapers.com/wp-content/themes/backbone/functions/timthumb.php?src=wp-content/uploads/2017/03/Sowers-Cemetary-edited.jpg&amp;w=100&amp;h=100&amp;zc=1&amp;q=90"/>
    	<meta property="og:site_name" content="" />
	<meta property="fb:admins" content="" />
	    
    <meta name="viewport" content="width=1024,maximum-scale=1.0" />
  
	<link href="http://ramblernewspapers.com/wp-content/themes/foodmagz/style.css" rel="stylesheet" type="text/css" />    
	
		<meta name="viewport" content="width=device-width, initial-scale=1"/>
		<link href='http://fonts.googleapis.com/css?family=Arvo:700' rel='stylesheet' type='text/css'>
	<link href="http://ramblernewspapers.com/wp-content/themes/foodmagz/includes/css/colabs-css.css" rel="stylesheet" type="text/css" />  
<!-- Custom Favicon -->
<link rel="shortcut icon" href="http://ramblernewspapers.com/wp-content/uploads/2013/08/RN.com_.Header.gif"/>

<!-- CoLabs Shortcodes CSS -->
<link href="http://ramblernewspapers.com/wp-content/themes/backbone/functions/css/shortcodes.css" rel="stylesheet" type="text/css" />

<!-- Custom Stylesheet -->
<link href="http://ramblernewspapers.com/wp-content/uploads/foodmagz-custom/custom.css" rel="stylesheet" type="text/css" />
<!-- Start Shareaholic Analytics -->
<script type="text/javascript">
  (function() {
  var dgh = document.createElement("script"); dgh.type = "text/javascript";dgh.async = true;
  dgh.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'dtym7iokkjlif.cloudfront.net/dough/1.0/recipe.js';
  var s = document.getElementsByTagName("script")[0]; s.parentNode.insertBefore(dgh, s);
  })();
</script>
<!-- End Shareaholic Analytics -->
<link rel="dns-prefetch" href="//connect.facebook.net" />
<link rel="alternate" type="application/rss+xml" title="Rambler Newspapers &raquo; Feed" href="http://ramblernewspapers.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Rambler Newspapers &raquo; Comments Feed" href="http://ramblernewspapers.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Rambler Newspapers &raquo; iCal Feed" href="http://ramblernewspapers.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Rambler Newspapers &raquo; Volunteers help maintain Sowers Cemetery Comments Feed" href="http://ramblernewspapers.com/2017/03/volunteers-help-maintain-sowers-cemetery/feed/" />
<link rel='stylesheet' id='pmpro_frontend-css'  href='http://ramblernewspapers.com/wp-content/plugins/paid-memberships-pro/css/frontend.css?ver=1.8.4.2' type='text/css' media='screen' />
<link rel='stylesheet' id='pmpro_print-css'  href='http://ramblernewspapers.com/wp-content/plugins/paid-memberships-pro/css/print.css?ver=1.8.4.2' type='text/css' media='print' />
<link rel='stylesheet' id='advpsStyleSheet-css'  href='http://ramblernewspapers.com/wp-content/plugins/advanced-post-slider/advps-style.css?ver=4.1.16' type='text/css' media='all' />
<link rel='stylesheet' id='pptwj-widget-tab-css-css'  href='http://ramblernewspapers.com/wp-content/plugins/popular-posts-tab-widget-for-jetpack/tab.css?ver=4.1.16' type='text/css' media='all' />
<link rel='stylesheet' id='wptt_front-css'  href='http://ramblernewspapers.com/wp-content/plugins/wp-twitter-feeds/css/admin_style.min.css?ver=4.1.16' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_image_widget-css'  href='http://ramblernewspapers.com/wp-content/plugins/jetpack/modules/widgets/image-widget/style.css?ver=20140808' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='http://ramblernewspapers.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://ramblernewspapers.com/wp-content/plugins/jetpack/css/jetpack.css?ver=3.6' type='text/css' media='all' />
<script type='text/javascript' src='http://ramblernewspapers.com/wp-includes/js/jquery/jquery.js?ver=1.11.1'></script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.2.1'></script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-content/plugins/paid-memberships-pro/js/paid-memberships-pro.js?ver=4.1.16'></script>
<script type='text/javascript' src='http://cdn.embedly.com/widgets/platform.js?ver=4.1.16'></script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-content/plugins/advanced-post-slider/js/advps.frnt.script.js?ver=4.1.16'></script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-content/plugins/advanced-post-slider/bxslider/jquery.bxslider.min.js?ver=4.1.16'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var PPTWJ = {"ajaxUrl":"http:\/\/ramblernewspapers.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-content/plugins/popular-posts-tab-widget-for-jetpack/tab.js?ver=4.1.16'></script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-content/themes/foodmagz/includes/js/plugins.js?ver=4.1.16'></script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-content/themes/foodmagz/includes/js/scripts.js?ver=4.1.16'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://ramblernewspapers.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://ramblernewspapers.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Volunteers bring Seuss stories to life' href='http://ramblernewspapers.com/2017/03/volunteers-bring-seuss-stories-to-life/' />
<meta name="generator" content="WordPress 4.1.16" />
<link rel='canonical' href='http://ramblernewspapers.com/2017/03/volunteers-help-maintain-sowers-cemetery/' />
<link rel='shortlink' href='http://wp.me/p3vbfn-4tl' />
<!-- <meta name="NextGEN" version="2.1.62" /> -->

<!-- CoLabs Color Scheme -->
<style type="text/css">

</style>
<!-- /CoLabs Color Scheme -->


<!-- Theme version -->
<meta name="generator" content="FoodMagz 1.1.8" />
<meta name="generator" content="CoLabsFramework 1.8.6" />
	
	<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="http://ramblernewspapers.com/feed/" />
	<link rel="pingback" href="http://ramblernewspapers.com/xmlrpc.php" />
	<link rel="alternate" type="text/xml" title="RSS .92" href="http://ramblernewspapers.com/feed/rss/" />
	<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="http://ramblernewspapers.com/feed/atom/" />
<meta property="og:site_name" content="Rambler Newspapers" />
<meta property="og:type" content="article" />
<meta property="og:locale" content="en_US" />
<meta property="fb:app_id" content="477513062334887" />
<meta property="og:url" content="http://ramblernewspapers.com/2017/03/volunteers-help-maintain-sowers-cemetery/" />
<meta property="og:title" content="Volunteers help maintain Sowers Cemetery" />
<meta property="og:description" content="Photo: Volunteers clear trees and brush at the century-old Sowers Cemetery. /Photo by John Starkey Volunteers arrived at Sowers Cemetery in Irving on Saturday morning, Feb. 4, to clean and beautify the aging graveyard. “We did a lot more tree trimming and pruning this year&hellip;" />
<meta property="og:image" content="http://ramblernewspapers.com/wp-content/uploads/2017/03/Sowers-Cemetary-edited.jpg" />
<meta property="og:image:width" content="3162" />
<meta property="og:image:height" content="2386" />
<meta property="article:published_time" content="2017-03-13T19:21:28+00:00" />
<meta property="article:modified_time" content="2017-03-13T19:21:28+00:00" />
<meta property="article:author" content="http://ramblernewspapers.com/author/vaughn-zel-lloyd/" />
<meta property="article:section" content="Community Events" />
<meta property="article:tag" content="Featured Stories" />
<meta property="article:tag" content="Irving" />

<style id="custom-css-css">/*
Welcome to Custom CSS!

CSS (Cascading Style Sheets) is a kind of code that tells the browser how
to render a web page. You may delete these comments and get started with
your customizations.

By default, your stylesheet will be loaded after the theme stylesheets,
which means that your rules can take precedence and override the theme CSS
rules. Just write here what you want to change, you don't need to copy all
your theme's stylesheet content.
*/</style>
<link rel='stylesheet' id='embedly_font_end-css'  href='http://ramblernewspapers.com/wp-content/plugins/embedly/css/embedly-frontend.css?ver=4.1.16' type='text/css' media='all' />
</head>
<body class="single single-post postid-17195 single-format-standard three-col-left width-980 three-col-left-980 unknown">

<div class="container">
  <div class="row-main">

    <header class="top-section">
      <hgroup class="logo">
        <h1 class="site-title">
		<a href="http://ramblernewspapers.com/">
		<img src="http://ramblernewspapers.com/wp-content/uploads/2013/08/RN.com_.Header.gif" alt="Rambler Newspapers" />		</a></h1>
        <h2 class="site-tagline">Serving Irving, Las Colinas, Valley Ranch, Coppell and DFW International Airport</h2>
      </hgroup><!-- .logo -->

      <form class="search-box" action="">
        <input type="text" name="s" value="" placeholder="Search">
        <input type="submit" value="Search">
        		<p>

        </p>
		      </form><!-- .search-box -->
    </header><!-- .top-section -->



    <nav class="main-nav">
      <a class="btn-navbar collapsed">
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
      </a>
      
      <div class="nav-collapse collapse">
        <div class=" megaWrapper"><ul id="menu-top-navigation" class="colabs_mega"><li id="menu-item-25" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children"><a href="http://ramblernewspapers.com/category/news/">News</a>


<ul class="sub-menu">
	<li id="menu-item-23" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children"><a href="http://ramblernewspapers.com/category/irving/">Irving</a>
	<ul class="sub-menu">
		<li id="menu-item-5530" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/irvingscholars/">Irving Scholars</a></li>
		<li id="menu-item-5534" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="http://ramblernewspapers.com/irving-isd-photo-gallery/">Irving ISD Photo Gallery</a></li>
	</ul>
</li>
	<li id="menu-item-22" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://ramblernewspapers.com/category/coppell/">Coppell</a>
	<ul class="sub-menu">
		<li id="menu-item-5531" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/coppellscholars/">Coppell Scholars</a></li>
	</ul>
</li>
	<li id="menu-item-1028" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/news/dfw-international/">DFW Area Aviation</a></li>
	<li id="menu-item-8792" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/news/contributed/">Contributed</a></li>
</ul>
</li>
<li id="menu-item-30" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children"><a href="http://ramblernewspapers.com/category/local/">Local</a>


<ul class="sub-menu">
	<li id="menu-item-1535" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent"><a href="http://ramblernewspapers.com/category/local/community-events/">Community Events</a></li>
</ul>
</li>
<li id="menu-item-11486" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/arts-entertainment/">Arts &#038; Entertainment</a></li>
<li id="menu-item-29" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/sports/">Sports</a></li>
<li id="menu-item-13655" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/home-health/">Home &#038; Health</a></li>
<li id="menu-item-28" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://ramblernewspapers.com/category/opinion/">Opinion</a>


<ul class="sub-menu">
	<li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/opinion/letters-to-the-editor/">Letters to the Editor</a></li>
</ul>
</li>
<li id="menu-item-7844" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children"><a href="http://ramblernewspapers.com/contact/">Contact</a>


<ul class="sub-menu">
	<li id="menu-item-9070" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://ramblernewspapers.com/contact/about-rambler-newspapers/">About Rambler Newspapers</a></li>
	<li id="menu-item-11209" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://ramblernewspapers.com/contact/careers/">Careers</a></li>
</ul>
</li>
<li id="menu-item-4298" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://ramblernewspapers.com/category/newspaper-archives/">Archives</a>


<ul class="sub-menu">
	<li id="menu-item-4305" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/">Irving Rambler</a>
	<ul class="sub-menu">
		<li id="menu-item-16496" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/2017/">2017</a></li>
		<li id="menu-item-14071" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/2016/">2016</a></li>
		<li id="menu-item-11312" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2015/">2015</a></li>
		<li id="menu-item-5062" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2014-irving-rambler-archive/">2014</a></li>
		<li id="menu-item-4307" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2013-irving-rambler-archive/">2013</a></li>
		<li id="menu-item-4306" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2012-irving-rambler-archive/">2012</a></li>
		<li id="menu-item-4324" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2011/">2011</a></li>
		<li id="menu-item-4323" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2010/">2010</a></li>
		<li id="menu-item-4322" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2009/">2009</a></li>
		<li id="menu-item-4321" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2008/">2008</a></li>
		<li id="menu-item-4320" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2007/">2007</a></li>
		<li id="menu-item-4319" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2006/">2006</a></li>
		<li id="menu-item-4318" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2005/">2005</a></li>
		<li id="menu-item-4317" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2004/">2004</a></li>
	</ul>
</li>
</ul>
</li>
</ul></div>      </div>
    </nav><!-- .main-menu -->


    <div class="main-container">
      <div class="row">
<div class="innercontainer column col9">
			<div class="ads ads-top">
		<!-- Beginning PassBack for Ad unit BENN/Irving_Rambler ### size: [[728,90]] -->
<script type='text/javascript' src='http://www.googletagservices.com/tag/js/gpt.js'>
googletag.pubads().definePassback('6785150/BENN/Irving_Rambler', [[728,90]]).setTargeting('fold',['ATF']).display();
</script>
<!-- End Passback -->		</div><!-- .ads-top -->
	
    <div class="row">
		        <div class="post-17195 post type-post status-publish format-standard hentry category-community-events category-featured-stories category-irving content column three-col-left col5">
  				<div class="breadcrumb breadcrumbs colabs-breadcrumbs"><div class="breadcrumb-trail"><span class="trail-before"><span class="breadcrumb-title">You are here:</span></span> <a href="http://ramblernewspapers.com" title="Rambler Newspapers" rel="home" class="trail-begin">Home</a> <span class="sep">&raquo;</span> <span class="trail-end">Volunteers help maintain Sowers Cemetery</span></div></div>  				  					<div class="entry-post">
		
		<h3 class="entry-title">Volunteers help maintain Sowers Cemetery</h3>	<p class="entry-meta">
		<time class="entry-date">March 13, 2017</time> By <a href="http://ramblernewspapers.com/author/vaughn-zel-lloyd/" title="Posts by Vaughn-zel Lloyd" rel="author">Vaughn-zel Lloyd</a> In <a href="http://ramblernewspapers.com/category/local/community-events/" rel="category tag">Community Events</a>, <a href="http://ramblernewspapers.com/category/news/featured-stories/" rel="category tag">Featured Stories</a>, <a href="http://ramblernewspapers.com/category/irving/" rel="category tag">Irving</a>	</p>
	<span class="comment-count">0</span>
					<div class="entry-top">
				<a title="Volunteers help maintain Sowers Cemetery" href="http://ramblernewspapers.com/wp-content/uploads/2017/03/Sowers-Cemetary-edited.jpg" rel="lightbox"><img src="http://ramblernewspapers.com/wp-content/themes/backbone/functions/timthumb.php?src=wp-content/uploads/2017/03/Sowers-Cemetary-edited.jpg&amp;w=500&amp;h=&amp;zc=1&amp;q=90" alt="Volunteers help maintain Sowers Cemetery" class="colabs-image"  /></a>			</div>
			
				<div class="entry-content">
			<p><em><strong>Photo:</strong> Volunteers clear trees and brush at the century-old Sowers Cemetery. /Photo by John Starkey</em></p>
<p>Volunteers arrived at Sowers Cemetery in Irving on Saturday morning, Feb. 4, to clean and beautify the aging graveyard.</p>
<p>“We did a lot more tree trimming and pruning this year than we did in the previous event,” City Councilman Gerald Farris said. “The property is about four acres, so it required a lot of walking to drag&nbsp;all those limbs into the roll off at the back of the property.&nbsp;</p>
<p>“We also did a lot of fencerow cleanup on the northeast fence. Several teams were able to prop up some of the settled gravestones and set some of the broken ones. Its importance is in the names on the gravestones. Many of the names are of those that settled&nbsp;this&nbsp;area and most of&nbsp;our parks, streets and schools are named after them. This represents over 150 years of Irving history and even&nbsp;predates the existence of&nbsp;Irving, Texas.”</p>
<p>The cemetery, located on Pioneer Drive near Beltline, was created along Sowers Road. The roads have changed, but the cemetery remains.&nbsp;</p>
<p>Kathy Bognfeldt has four generations of family buried at the site.</p>
<p>“[I enjoy] seeing people that I’ve known all my life out there and reconnecting with families that I have known through church or just growing up in Irving,” Bognfeldt said. “It was great to see scouts, the AMBUCS, and the fire department out there and other groups from the community coming out and acknowledging the importance of the cemetery.</p>
<p>“[The cemetery is] important for me, because I have four generations of family there. It’s important for the community, because that is a historic site and Irving is made up of several different communities including the Sowers community, which was home to Irving settlers. Important figures in the community were buried there in that cemetery,” she said. “It needs to be upheld and up kept. I think it’s a great thing for the community to come out and support that heritage.”</p>
<p>Alan Goodgame, a volunteer for the Irving Fire Department, said there are multiple cemeteries in the city of Irving that could use a little cleaning up.</p>
<p>“I think it has been cool to see the restoration while enjoying history and really being able to walk out here and see what they have done,” Goodgame said. “I actually visit old cemeteries. We have more cemeteries in Irving that could use this.”</p>
<p>Farris, who organized the event, hopes to make the event into an annual clean up.</p>
<p>“I can envision us having smaller, more specialized work events also,” Farris said. “For example, we have a lot of gravestones that need attention and areas that need fill dirt.&nbsp;There was also a large tree [that needed] trimming, but we couldn&#8217;t get to it because of lack of equipment and expertise.”</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-17195" class="share-facebook sd-button share-icon" href="http://ramblernewspapers.com/2017/03/volunteers-help-maintain-sowers-cemetery/?share=facebook" target="_blank" title="Share on Facebook"><span>Facebook</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon" href="http://ramblernewspapers.com/2017/03/volunteers-help-maintain-sowers-cemetery/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon" href="http://ramblernewspapers.com/2017/03/volunteers-help-maintain-sowers-cemetery/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div>		</div>
		<div class="social_share"><div class="colabs-sc-twitter left"><a href="http://twitter.com/share" class="twitter-share-button" data-url="http://ramblernewspapers.com/2017/03/volunteers-help-maintain-sowers-cemetery/" data-via="ramblerupdate"data-count="horizontal" data-count="horizontal">Tweet</a><script type="text/javascript" src="http://platform.twitter.com/widgets.js"></script></div>
<div class="colabs-fblike fl">
<iframe src="http://www.facebook.com/plugins/like.php?href=http://ramblernewspapers.com/2017/03/volunteers-help-maintain-sowers-cemetery/&amp;layout=button_count&amp;show_faces=false&amp;width=85&amp;action=like&amp;colorscheme=light&amp;font=arial" scrolling="no" frameborder="0" allowTransparency="true" style="border:none; overflow:hidden; width:85px; height:30px;"></iframe>
</div>
	<div class="clear"></div></div>				<p class="entry-info"></p>
<div class="entry-author">
	<span class="profile-image"><img src="http://0.gravatar.com/avatar/ed0b8f204829f496bcffc96eac651023?s=55&amp;d=http%3A%2F%2F0.gravatar.com%2Favatar%2Fad516503a11cd5ca435acc9bb6523536%3Fs%3D55&amp;r=G" width="55" height="55" alt="" class="avatar avatar-55 wp-user-avatar wp-user-avatar-55 photo avatar-default" /></span>
	<div class="profile-content author-detail">
		<h3>About <a href="http://ramblernewspapers.com/author/vaughn-zel-lloyd/">Vaughn-zel Lloyd</a></h3>
        <p>		        <a href="http://ramblernewspapers.com/author/vaughn-zel-lloyd/">
				View all posts by Vaughn-zel Lloyd <span class="meta-nav">&rarr;</span>			</a>
		</p>
			</div>
	<div class="clear"></div>
</div><!--/.entry-author-->
	        <div id="page-top" class="post-entries">
	            <div class="page-prev fl"><a href="http://ramblernewspapers.com/2017/03/volunteers-bring-seuss-stories-to-life/" rel="prev"><span class="meta-nav">&larr;</span> Volunteers bring Seuss stories to life</a></div>
	            <div class="page-next fr"></div>
	            <div class="clear"></div>
	        </div><!--/#page-top-->
	
			</div>



<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<div class="fb-social-plugin comment-form fb-comments" id="commentform" data-href="http://ramblernewspapers.com/2017/03/volunteers-help-maintain-sowers-cemetery/" data-width="462" data-order-by="social"></div>
</div></div>
  									  
  					
        </div><!-- .content -->
		 
		<div id="sidebar-second" class="sidebar sidebar-right column col4">
	<div id="image-7" class="widget widget_image"><div class="jetpack-image-container"><a href="http://www.christianscienceirving.com/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/FCCSedit2.jpg" class="alignnone" width="640" height="272" /></a></div>
</div><div id="image-2" class="widget widget_image"><div class="jetpack-image-container"><a href="http://www.chateauonwildbriarlake.com/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/5191-800x450.jpg" class="aligncenter" width="431" height="604" /></a></div>
</div><div id="image-9" class="widget widget_image"><div class="jetpack-image-container"><a href="https://www.facebook.com/Betcha-Bingo-813975168680884/?rf=188739101162941"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/BETCHA-LOGO-1024x87.jpg" class="alignnone" /></a></div>
</div><div id="wptt_twittertweets-2" class="widget wptt_TwitterTweets"><h4 class="widget-title">Latest Tweets</h4>			

<ul class="fetched_tweets light">
						    			        <li class="tweets_avatar">
			        	<div class="tweet_wrap"><div class="wdtf-user-card ltr"><div class="clear"></div></div>			       		<div class="tweet_data">
			        	Volunteers help maintain Sowers Cemetery | <a href="https://t.co/NF7wPaNJwr" target="_blank" rel="nofollow">https://t.co/NF7wPaNJwr</a>
<a href="http://twitter.com/search?q=%23SowersCemetery" target="_blank" rel="nofollow">#SowersCemetery</a> <a href="http://twitter.com/search?q=%23Irving" target="_blank" rel="nofollow">#Irving</a> <a href="https://t.co/t8gy8HWC30" target="_blank" rel="nofollow">https://t.co/t8gy8HWC30</a>			        	</div>
			            <br/>
			            <div class="clear"></div>
			            <div class="times">
			            <em>
			            
						<a href="http://www.twitter.com/@dfw_rambler" target="_blank" title="Follow @dfw_rambler on Twitter [Opens new window]">
							5h							</a>
			            </em>
			            </div>
												<div class="clear"></div>
</div><div class="clear"></div>
			        </li>
			    
						</ul>
			
			</div><div id="image-5" class="widget widget_image"><div class="jetpack-image-container"><a href="http://www.unitychurchofirving.com/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/5185.png" class="alignnone" width="1024" height="512" /></a></div>
</div>	
			<div id="pptwj-2" class="widget pptwj">
			
			<div class="pptwj-tabs-wrap">
	
				<ul class="tab-links">
										
					<li class="popular"><a href="#tab-pop">Popular</a></li>										<li class="latest"><a href="#tab-latest">Latest</a></li>				</ul>
				
				<div class="clear"></div>
	
				<div class="boxes box inside">
	
						
										<div id="tab-pop">
						<ul class="tab-filter-list" data-type="popular">
							<li>
																	<a href="#" data-time="day" data-numberposts="10" data-thumb="3" data-tab="popular">Today</a>
																	<a href="#" data-time="week" data-numberposts="10" data-thumb="3" data-tab="popular">Week</a>
																	<a href="#" data-time="month" data-numberposts="10" data-thumb="3" data-tab="popular">Month</a>
																	<a href="#" data-time="all" data-numberposts="10" data-thumb="3" data-tab="popular">All</a>
															</li>
						</ul>
						<ul class="list">
									<li class="odd">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/02/apparition-hill-brings-medjugorje-to-audiences/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/02/Holly-and-Matt-2-edited-1024x576-150x84.jpg" alt="Apparition Hill brings Medjugorje to audiences" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Apparition Hill brings Medjugorje to audiences" href="http://ramblernewspapers.com/2017/02/apparition-hill-brings-medjugorje-to-audiences/">Apparition Hill brings Medjugorje to audiences</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="even">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/02/guide-dog-puppies-begin-basic-training-in-texas/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/02/1-150x99.jpg" alt="Guide dog puppies begin basic training in Texas" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Guide dog puppies begin basic training in Texas" href="http://ramblernewspapers.com/2017/02/guide-dog-puppies-begin-basic-training-in-texas/">Guide dog puppies begin basic training in Texas</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="odd">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/02/irving-fire-department-hosts-annual-banquet/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/02/Irvng-Fire-Feb-2017-2110741-1024x604-150x88.jpg" alt="Irving Fire Department hosts annual banquet" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Irving Fire Department hosts annual banquet" href="http://ramblernewspapers.com/2017/02/irving-fire-department-hosts-annual-banquet/">Irving Fire Department hosts annual banquet</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="even">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/02/texas-workforce-commission-presents-grant-for-job-training/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/02/N1309P26010C-1020x574-150x84.jpg" alt="Texas Workforce Commission presents grant for job training" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Texas Workforce Commission presents grant for job training" href="http://ramblernewspapers.com/2017/02/texas-workforce-commission-presents-grant-for-job-training/">Texas Workforce Commission presents grant for job training</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="odd">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/02/pastor-george-celebrates-80th-birthday/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/02/Pastor-George-833x615-150x111.jpg" alt="Pastor George celebrates 80th birthday" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Pastor George celebrates 80th birthday" href="http://ramblernewspapers.com/2017/02/pastor-george-celebrates-80th-birthday/">Pastor George celebrates 80th birthday</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="even">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/02/van-duyne-urges-innovation-global-access-in-state-of-the-city-speech/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/02/State-of-the-City-1024x669-150x98.jpg" alt="Van Duyne urges innovation, global access in State of the City Speech" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Van Duyne urges innovation, global access in State of the City Speech" href="http://ramblernewspapers.com/2017/02/van-duyne-urges-innovation-global-access-in-state-of-the-city-speech/">Van Duyne urges innovation, global access in State of the City Speech</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="odd">
										<a class="post-thumb" href="http://ramblernewspapers.com/2016/04/making-phased-retirement-work-for-you/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/04/N1105P33006C-1024x678-150x99.jpg" alt="Making phased retirement work for you" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Making phased retirement work for you" href="http://ramblernewspapers.com/2016/04/making-phased-retirement-work-for-you/">Making phased retirement work for you</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="even">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/02/irving-isd-students-ink-letters-of-intent/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/02/sign-150x137.jpg" alt="Irving ISD Students Ink Letters of Intent" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Irving ISD Students Ink Letters of Intent" href="http://ramblernewspapers.com/2017/02/irving-isd-students-ink-letters-of-intent/">Irving ISD Students Ink Letters of Intent</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="odd">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/02/irving-music-factory-set-to-open-labor-day/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/02/DSC_1352-1024x671-150x98.jpg" alt="Irving Music Factory set to open Labor Day" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Irving Music Factory set to open Labor Day" href="http://ramblernewspapers.com/2017/02/irving-music-factory-set-to-open-labor-day/">Irving Music Factory set to open Labor Day</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="even">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/02/rambler-02-25-2017/"><img src="http://ramblernewspapers.com/wp-content/plugins/popular-posts-tab-widget-for-jetpack/default.png" alt="Rambler 02-25-2017" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Rambler 02-25-2017" href="http://ramblernewspapers.com/2017/02/rambler-02-25-2017/">Rambler 02-25-2017</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
								</ul>
					</div><!-- #tab-pop -->
															<div id="tab-latest">
						<ul class="list">
										<li class="odd">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/03/volunteers-help-maintain-sowers-cemetery/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/03/Sowers-Cemetary-edited-150x113.jpg" alt="Volunteers help maintain Sowers Cemetery" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Volunteers help maintain Sowers Cemetery" href="http://ramblernewspapers.com/2017/03/volunteers-help-maintain-sowers-cemetery/">Volunteers help maintain Sowers Cemetery</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="even">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/03/volunteers-bring-seuss-stories-to-life/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/03/Dr.-Seuss-edited-1024x683-150x100.jpg" alt="Volunteers bring Seuss stories to life" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Volunteers bring Seuss stories to life" href="http://ramblernewspapers.com/2017/03/volunteers-bring-seuss-stories-to-life/">Volunteers bring Seuss stories to life</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="odd">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/03/court-of-appeals-orders-irving-to-include-mayoral-candidate-on-ballot/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/03/N1506P37007C-1-1024x1024-150x150.jpg" alt="Court of Appeals orders Irving to include mayoral candidate on ballot" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Court of Appeals orders Irving to include mayoral candidate on ballot" href="http://ramblernewspapers.com/2017/03/court-of-appeals-orders-irving-to-include-mayoral-candidate-on-ballot/">Court of Appeals orders Irving to include mayoral candidate on ballot</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="even">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/03/author-luncheon-helps-educators-inspire-teens-to-read/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/03/IMG_4444-1024x758-150x111.jpg" alt="Author luncheon helps educators inspire teens to read" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Author luncheon helps educators inspire teens to read" href="http://ramblernewspapers.com/2017/03/author-luncheon-helps-educators-inspire-teens-to-read/">Author luncheon helps educators inspire teens to read</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="odd">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/03/rambler-03-11-2017/"><img src="http://ramblernewspapers.com/wp-content/plugins/popular-posts-tab-widget-for-jetpack/default.png" alt="Rambler 03-11-2017" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Rambler 03-11-2017" href="http://ramblernewspapers.com/2017/03/rambler-03-11-2017/">Rambler 03-11-2017</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="even">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/03/horrorcomedy-hits-the-mark/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/03/N1509P14001C-1024x611-150x90.jpg" alt="Film Review: Horror/comedy hits the mark" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Film Review: Horror/comedy hits the mark" href="http://ramblernewspapers.com/2017/03/horrorcomedy-hits-the-mark/">Film Review: Horror/comedy hits the mark</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="odd">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/03/save-the-date-2/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/03/N1510P62005C-1020x678-150x100.jpg" alt="Save the Date!" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Save the Date!" href="http://ramblernewspapers.com/2017/03/save-the-date-2/">Save the Date!</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="even">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/03/win-a-pair-of-free-tickets/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/03/beatles-975x1024-150x158.jpg" alt="Win a pair of FREE tickets!" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Win a pair of FREE tickets!" href="http://ramblernewspapers.com/2017/03/win-a-pair-of-free-tickets/">Win a pair of FREE tickets!</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="odd">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/03/not-so-mobile-america-what-honolulu-and-detroit-residents-have-in-common/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/03/N1504P64005C-1024x768-150x113.jpg" alt="Not-so-mobile America: What Honolulu and Detroit residents have in common" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Not-so-mobile America: What Honolulu and Detroit residents have in common" href="http://ramblernewspapers.com/2017/03/not-so-mobile-america-what-honolulu-and-detroit-residents-have-in-common/">Not-so-mobile America: What Honolulu and Detroit residents have in common</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="even">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/03/irving-isd-shines-at-state-academic-decathlon-meet/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/03/N1701P38008C-1024x678-150x99.jpg" alt="Irving ISD shines at state Academic Decathlon meet" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Irving ISD shines at state Academic Decathlon meet" href="http://ramblernewspapers.com/2017/03/irving-isd-shines-at-state-academic-decathlon-meet/">Irving ISD shines at state Academic Decathlon meet</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
								</ul>
					</div><!-- #tab-latest -->
															<div class="pptwj-loader"><img src="http://ramblernewspapers.com/wp-includes//images/wpspin-2x.gif" alt="Ajax spinner"></div>
				</div><!-- /.boxes -->
			</div><!-- /pptwj-tabs-wrap -->

			</div>			<div id="categories-2" class="widget widget_categories"><h4 class="widget-title">Find what you&#8217;re looking for? Browse News by Category</h4><select name='cat' id='cat' class='postform' >
	<option value='-1'>Select Category</option>
	<option class="level-0" value="177">2004</option>
	<option class="level-0" value="176">2005</option>
	<option class="level-0" value="175">2006</option>
	<option class="level-0" value="174">2007</option>
	<option class="level-0" value="173">2008</option>
	<option class="level-0" value="172">2009</option>
	<option class="level-0" value="171">2010</option>
	<option class="level-0" value="170">2011</option>
	<option class="level-0" value="189">2011</option>
	<option class="level-0" value="163">2012</option>
	<option class="level-0" value="165">2012</option>
	<option class="level-0" value="167">2012</option>
	<option class="level-0" value="164">2013</option>
	<option class="level-0" value="166">2013</option>
	<option class="level-0" value="168">2013</option>
	<option class="level-0" value="185">2014</option>
	<option class="level-0" value="183">2014</option>
	<option class="level-0" value="184">2014</option>
	<option class="level-0" value="214">2015</option>
	<option class="level-0" value="220">2016</option>
	<option class="level-0" value="221">2017</option>
	<option class="level-0" value="154">Archives</option>
	<option class="level-0" value="19">Arlington</option>
	<option class="level-0" value="216">Arts &amp; Entertainment</option>
	<option class="level-0" value="24">Church Directory</option>
	<option class="level-0" value="144">Community Events</option>
	<option class="level-0" value="186">Contributed</option>
	<option class="level-0" value="4">Coppell</option>
	<option class="level-0" value="161">Coppell Rambler</option>
	<option class="level-0" value="148">Coppell Scholars</option>
	<option class="level-0" value="191">Correction</option>
	<option class="level-0" value="25">Dallas</option>
	<option class="level-0" value="218">DFW Area Aviation</option>
	<option class="level-0" value="26">DFW International</option>
	<option class="level-0" value="162">DFW News Flash</option>
	<option class="level-0" value="27">Editorials</option>
	<option class="level-0" value="5">Entertainment</option>
	<option class="level-0" value="22">Featured Stories</option>
	<option class="level-0" value="6">Features</option>
	<option class="level-0" value="28">Flower Mound</option>
	<option class="level-0" value="187">Fort Worth</option>
	<option class="level-0" value="29">Grand Prarie</option>
	<option class="level-0" value="30">Grapevine</option>
	<option class="level-0" value="31">Guest Columns</option>
	<option class="level-0" value="219">Home &amp; Health</option>
	<option class="level-0" value="9">Irving</option>
	<option class="level-0" value="160">Irving Rambler</option>
	<option class="level-0" value="147">Irving Scholars</option>
	<option class="level-0" value="217">Jobs</option>
	<option class="level-0" value="32">Las Colinas</option>
	<option class="level-0" value="33">Letters to the Editor</option>
	<option class="level-0" value="34">Lewisville</option>
	<option class="level-0" value="10">Lifestyle</option>
	<option class="level-0" value="3">Local</option>
	<option class="level-0" value="35">Local News</option>
	<option class="level-0" value="11">News</option>
	<option class="level-0" value="159">Newspaper Archives</option>
	<option class="level-0" value="12">Obituaries</option>
	<option class="level-0" value="13">Opinion</option>
	<option class="level-0" value="14">Reader&#8217;s Choice</option>
	<option class="level-0" value="15">Service Organizations</option>
	<option class="level-0" value="16">South Lake</option>
	<option class="level-0" value="17">Sports</option>
	<option class="level-0" value="149">Texas Wild</option>
	<option class="level-0" value="188">This week</option>
	<option class="level-0" value="1">Uncategorized</option>
	<option class="level-0" value="18">Valley Ranch</option>
	<option class="level-0" value="145">Volunteer Opportunities</option>
</select>

<script type='text/javascript'>
/* <![CDATA[ */
	var dropdown = document.getElementById("cat");
	function onCatChange() {
		if ( dropdown.options[dropdown.selectedIndex].value > 0 ) {
			location.href = "http://ramblernewspapers.com/?cat="+dropdown.options[dropdown.selectedIndex].value;
		}
	}
	dropdown.onchange = onCatChange;
/* ]]> */
</script>

</div><div id="image-3" class="widget widget_image"><div class="jetpack-image-container"><a href="https://www.statefarm.com/agent/US/TX/Irving/Bill-Hooten-4XDNY1YS000"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/Hooten-High-Quality-1024x170.jpg" class="alignnone" width="1024" height="170" /></a></div>
</div><div id="image-13" class="widget widget_image"><div class="jetpack-image-container"><a href="http://www.beltlinechurch.com/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/5227-800x188.jpg" class="alignnone" /></a></div>
</div><div id="image-4" class="widget widget_image"><div class="jetpack-image-container"><a href="http://verde.tech/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/verdelogo-2-800x196.jpg" class="alignnone" width="800" height="196" /></a></div>
</div></div><!-- /#sidebar-alt -->
    </div>
</div>
	  
<div class="sidebar sidebar-left col3 column">
	<div id="text-4" class="widget widget_text">			<div class="textwidget"><a href="https://twitter.com/DFW_Rambler" onclick="__gaTracker('send', 'event', 'outbound-widget', 'https://twitter.com/DFW_Rambler', 'Follow @DFW_Rambler');" class="twitter-follow-button" data-show-count="false">Follow @DFW_Rambler</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div>
		</div><div id="colabs_postcat-3" class="widget widget_colabs_postcat">	
			<h4 class="widget-title">Current editions</h4>			<ul>
								<li>
										<p><a href="http://ramblernewspapers.com/2017/03/rambler-03-11-2017/">Rambler 03-11-2017</a></p>
				</li>	
								<li>
										<p><a href="http://ramblernewspapers.com/2017/03/rambler-03-04-2017/">Rambler 03-04-2017</a></p>
				</li>	
							</ul>
          			
        </div><div id="image-12" class="widget widget_image"><div class="jetpack-image-container"><a href="https://www.ppumc.org/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/ppumc-609x324.jpg" class="alignnone" /></a></div>
</div><div id="image-6" class="widget widget_image"><div class="jetpack-image-container"><a href="http://irvinghcc.com/home/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/Logo-Color-horse-for-chamber-Copy-1024x512.jpg" class="alignnone" /></a></div>
</div><div id="image-11" class="widget widget_image"><div class="jetpack-image-container"><a href="https://www.expresspros.com/IrvingTX/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/exp-emp-1024x320.jpg" class="alignnone" /></a></div>
</div><div id="colabs_postcat-2" class="widget widget_colabs_postcat">	
			<h4 class="widget-title">STORIES: REGIONAL AND STATEWIDE</h4>			<ul>
								<li>
					<a title="Film Review: Horror/comedy hits the mark" href="http://ramblernewspapers.com/2017/03/horrorcomedy-hits-the-mark/" ><img src="http://ramblernewspapers.com/wp-content/themes/backbone/functions/timthumb.php?src=wp-content/uploads/2017/03/N1509P14001C-1024x611.jpg&amp;w=138&amp;h=100&amp;zc=1&amp;q=90" alt="Film Review: Horror/comedy hits the mark" class="colabs-image"  /></a>					<p><a href="http://ramblernewspapers.com/2017/03/horrorcomedy-hits-the-mark/">Film Review: Horror/comedy hits the mark</a></p>
				</li>	
								<li>
					<a title="Not-so-mobile America: What Honolulu and Detroit residents have in common" href="http://ramblernewspapers.com/2017/03/not-so-mobile-america-what-honolulu-and-detroit-residents-have-in-common/" ><img src="http://ramblernewspapers.com/wp-content/themes/backbone/functions/timthumb.php?src=wp-content/uploads/2017/03/N1504P64005C-1024x768.jpg&amp;w=138&amp;h=100&amp;zc=1&amp;q=90" alt="Not-so-mobile America: What Honolulu and Detroit residents have in common" class="colabs-image"  /></a>					<p><a href="http://ramblernewspapers.com/2017/03/not-so-mobile-america-what-honolulu-and-detroit-residents-have-in-common/">Not-so-mobile America: What Honolulu and Detroit residents have in common</a></p>
				</li>	
								<li>
					<a title="TEXPEX delivers history through stamps" href="http://ramblernewspapers.com/2017/03/texpex-delivers-history-through-stamps/" ><img src="http://ramblernewspapers.com/wp-content/themes/backbone/functions/timthumb.php?src=wp-content/uploads/2017/03/Lyle-Picture-1024x673.jpg&amp;w=138&amp;h=100&amp;zc=1&amp;q=90&amp;a=t" alt="TEXPEX delivers history through stamps" class="colabs-image"  /></a>					<p><a href="http://ramblernewspapers.com/2017/03/texpex-delivers-history-through-stamps/">TEXPEX delivers history through stamps</a></p>
				</li>	
								<li>
					<a title="Young people invited to help stop distracted walking, driving" href="http://ramblernewspapers.com/2017/03/young-people-invited-to-help-stop-distracted-walking-driving/" ><img src="http://ramblernewspapers.com/wp-content/themes/backbone/functions/timthumb.php?src=wp-content/uploads/2017/03/N1208P60003C-850x642.jpg&amp;w=138&amp;h=100&amp;zc=1&amp;q=90" alt="Young people invited to help stop distracted walking, driving" class="colabs-image"  /></a>					<p><a href="http://ramblernewspapers.com/2017/03/young-people-invited-to-help-stop-distracted-walking-driving/">Young people invited to help stop distracted walking, driving</a></p>
				</li>	
								<li>
					<a title="Texas A&#038;M explores what firefighters can reveal about PTSD risk" href="http://ramblernewspapers.com/2017/02/texas-am-explores-what-firefighters-can-reveal-about-ptsd-risk/" ><img src="http://ramblernewspapers.com/wp-content/themes/backbone/functions/timthumb.php?src=wp-content/uploads/2017/02/N07A7270-850x891.jpg&amp;w=138&amp;h=100&amp;zc=1&amp;q=90&amp;a=t" alt="Texas A&#038;M explores what firefighters can reveal about PTSD risk" class="colabs-image"  /></a>					<p><a href="http://ramblernewspapers.com/2017/02/texas-am-explores-what-firefighters-can-reveal-about-ptsd-risk/">Texas A&#038;M explores what firefighters can reveal about PTSD risk</a></p>
				</li>	
								<li>
					<a title="Lakota warrior Eagle Elk honored in iconic image" href="http://ramblernewspapers.com/2017/02/lakota-warrior-eagle-elk-honored-in-iconic-image/" ><img src="http://ramblernewspapers.com/wp-content/themes/backbone/functions/timthumb.php?src=wp-content/uploads/2017/02/Robert-Eagle-Elk-with-Grandson-Loki-and-Artist-David-Smith-edited-1024x609.jpg&amp;w=138&amp;h=100&amp;zc=1&amp;q=90" alt="Lakota warrior Eagle Elk honored in iconic image" class="colabs-image"  /></a>					<p><a href="http://ramblernewspapers.com/2017/02/lakota-warrior-eagle-elk-honored-in-iconic-image/">Lakota warrior Eagle Elk honored in iconic image</a></p>
				</li>	
								<li>
					<a title="Texas home sales, prices set annual records for second year in a row " href="http://ramblernewspapers.com/2017/02/texas-home-sales-prices-set-annual-records-for-second-year-in-a-row/" ><img src="http://ramblernewspapers.com/wp-content/themes/backbone/functions/timthumb.php?src=wp-content/uploads/2017/02/N1602P29007C-1024x642.jpg&amp;w=138&amp;h=100&amp;zc=1&amp;q=90" alt="Texas home sales, prices set annual records for second year in a row " class="colabs-image"  /></a>					<p><a href="http://ramblernewspapers.com/2017/02/texas-home-sales-prices-set-annual-records-for-second-year-in-a-row/">Texas home sales, prices set annual records for second year in a row </a></p>
				</li>	
								<li>
					<a title="Guide dog puppies begin basic training in Texas" href="http://ramblernewspapers.com/2017/02/guide-dog-puppies-begin-basic-training-in-texas/" ><img src="http://ramblernewspapers.com/wp-content/themes/backbone/functions/timthumb.php?src=wp-content/uploads/2017/02/1.jpg&amp;w=138&amp;h=100&amp;zc=1&amp;q=90" alt="Guide dog puppies begin basic training in Texas" class="colabs-image"  /></a>					<p><a href="http://ramblernewspapers.com/2017/02/guide-dog-puppies-begin-basic-training-in-texas/">Guide dog puppies begin basic training in Texas</a></p>
				</li>	
								<li>
					<a title="Texas Workforce Commission presents grant for job training" href="http://ramblernewspapers.com/2017/02/texas-workforce-commission-presents-grant-for-job-training/" ><img src="http://ramblernewspapers.com/wp-content/themes/backbone/functions/timthumb.php?src=wp-content/uploads/2017/02/N1309P26010C-1020x574.jpg&amp;w=138&amp;h=100&amp;zc=1&amp;q=90" alt="Texas Workforce Commission presents grant for job training" class="colabs-image"  /></a>					<p><a href="http://ramblernewspapers.com/2017/02/texas-workforce-commission-presents-grant-for-job-training/">Texas Workforce Commission presents grant for job training</a></p>
				</li>	
								<li>
					<a title="North Texas kids compete in annual FIRST LEGO League robotics tournament" href="http://ramblernewspapers.com/2017/02/north-texas-kids-compete-in-annual-first-lego-league-robotics-tournament/" ><img src="http://ramblernewspapers.com/wp-content/themes/backbone/functions/timthumb.php?src=wp-content/uploads/2017/02/Lego-Robotics-1024x667.jpg&amp;w=138&amp;h=100&amp;zc=1&amp;q=90&amp;a=t" alt="North Texas kids compete in annual FIRST LEGO League robotics tournament" class="colabs-image"  /></a>					<p><a href="http://ramblernewspapers.com/2017/02/north-texas-kids-compete-in-annual-first-lego-league-robotics-tournament/">North Texas kids compete in annual FIRST LEGO League robotics tournament</a></p>
				</li>	
							</ul>
          			
        </div><div id="image-8" class="widget widget_image"><div class="jetpack-image-container"><a href="http://allamericanpest.net/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/American-Pest-Ad-cmyk-1024x535-800x412.jpg" class="alignnone" /></a></div>
</div>
<!-- Start - HTML Javascript Adder plugin v3.9 -->
<div id="html_javascript_adder-4" class="widget widget_html_javascript_adder">
<div class="hjawidget textwidget">
<!-- Beginning PassBack for Ad unit BENN/Irving_Rambler ### size: [[160,600]] -->
<script type='text/javascript' src='http://www.googletagservices.com/tag/js/gpt.js'>
googletag.pubads().definePassback('6785150/BENN/Irving_Rambler', [[160,600]]).setTargeting('fold',['ATF']).display();
</script>
<!-- End Passback -->
</div>
</div><!-- End - HTML Javascript Adder plugin v3.9 -->
</div><!-- /#sidebar -->
		</div><!-- .row -->
	</div><!-- .main-container -->


    <footer class="footer">
      <h4 class="logo-footer"><a href="http://ramblernewspapers.com/">Rambler Newspapers</a></h4>

      <p class="copyright"><!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WJ36PN"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-WJ36PN');</script>
<!-- End Google Tag Manager --></p>

      <nav class="footer-nav">
        <div class="n megaWrapper"><ul id="menu-bottom-navigation" class="colabs_mega"><li id="menu-item-17" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.ramblernewspapers.com">Home</a></li>
<li id="menu-item-1064" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://ramblernewspapers.com/contact/about-rambler-newspapers/">About</a></li>
<li id="menu-item-2287" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://ramblernewspapers.com/legal/">Privacy Policy &#038; Terms of Service</a></li>
<li id="menu-item-1063" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://ramblernewspapers.com/contact/">Contact</a></li>
<li id="menu-item-1062" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://ramblernewspapers.com/subscribe/">Subscribe</a></li>
</ul></div>      </nav><!-- .footer-nav -->
    </footer><!-- .footer -->

  </div><!-- .row-main -->
</div>
<!-- .container -->

<!-- ngg_resource_manager_marker --><script type='text/javascript' src='http://ramblernewspapers.com/wp-includes/js/comment-reply.min.js?ver=4.1.16'></script>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201711'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Maraa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.1.16'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var FB_WP=FB_WP||{};FB_WP.queue={_methods:[],flushed:false,add:function(fn){FB_WP.queue.flushed?fn():FB_WP.queue._methods.push(fn)},flush:function(){for(var fn;fn=FB_WP.queue._methods.shift();){fn()}FB_WP.queue.flushed=true}};window.fbAsyncInit=function(){FB.init({"xfbml":true,"appId":"477513062334887"});if(FB_WP && FB_WP.queue && FB_WP.queue.flush){FB_WP.queue.flush()}}
/* ]]> */
</script>
<script type="text/javascript">(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id)){return}js=d.createElement(s);js.id=id;js.src="http:\/\/connect.facebook.net\/en_US\/all.js";fjs.parentNode.insertBefore(js,fjs)}(document,"script","facebook-jssdk"));</script>
		<!-- Memberships powered by Paid Memberships Pro v1.8.4.2.
 -->
		<!-- Powered by WPtouch: 3.8.1 -->	<div style="display:none">
	<div class="grofile-hash-map-ed0b8f204829f496bcffc96eac651023">
	</div>
	</div>
		<script type="text/javascript">
			!function(d,s,id){
				var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';
				if(!d.getElementById(id)){
					js=d.createElement(s);
					js.id=id;js.src=p+"://platform.twitter.com/widgets.js";
					fjs.parentNode.insertBefore(js,fjs);
				}
			}(document,"script","twitter-wjs");
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
			<div id="sharing_email" style="display: none;">
		<form action="/2017/03/volunteers-help-maintain-sowers-cemetery/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
			<script> document.getElementById('jetpack-source_f_name').value = ''; </script>
			
			<img style="float: right; display: none" class="loading" src="http://ramblernewspapers.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='http://stats.wp.com/e-201711.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:3.6',blog:'51760413',post:'17195',tz:'-5',srv:'ramblernewspapers.com'} ]);
	_stq.push([ 'clickTrackerInit', '51760413', '17195' ]);
</script>
<div id="fb-root"></div> 


<!-- Native Ad Widget -->
<script type="text/javascript" src="http://code.jquery.com/jquery-1.7.1.min.js"></script>							
<script type="text/javascript" src="http://s3.amazonaws.com/ramblernewspapers/ramblernewspapers.js"></script>

</body>
</html>