<!DOCTYPE html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7 ie" lang="en"> <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8 ie7" lang="en"> <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9 ie8" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html xmlns="http://www.w3.org/1999/xhtml" lang="en-US"> <!--<![endif]-->

<head profile="http://gmpg.org/xfn/11">
	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
	<title>Luncheon turns lemons into lemonade  |  Rambler Newspapers | Serving Irving, Las Colinas, Valley Ranch, Coppell and DFW International Airport</title>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-67226227-1', 'auto');
  ga('send', 'pageview');

</script>
  <!--[if IE]>
    <script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script>
  <![endif]-->


	<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="robots" content="index, nofollow" />
<meta name="description" content="Thirty-one years ago, League of Volunteers member Bettye Davis began bringing slices of lemon cakes to council meetings. Every year since, Davis has been providing her prized cakes to help ..." />
<meta name="keywords" content="community events,featured stories,irving" />
		
		<meta property="og:title" content="Luncheon turns lemons into lemonade" />
	<meta property="og:type" content="article" />
	<meta property="og:url" content="http://ramblernewspapers.com/2017/05/luncheon-turns-lemons-into-lemonade/" />
	        <meta property="og:image" content="http://ramblernewspapers.com/wp-content/themes/backbone/functions/timthumb.php?src=wp-content/uploads/2017/05/Salvation-Army-officers-edited.jpg&amp;w=100&amp;h=100&amp;zc=1&amp;q=90"/>
    	<meta property="og:site_name" content="" />
	<meta property="fb:admins" content="" />
	    
    <meta name="viewport" content="width=1024,maximum-scale=1.0" />
  
	<link href="http://ramblernewspapers.com/wp-content/themes/foodmagz/style.css" rel="stylesheet" type="text/css" />    
	
		<meta name="viewport" content="width=device-width, initial-scale=1"/>
		<link href='http://fonts.googleapis.com/css?family=Arvo:700' rel='stylesheet' type='text/css'>
	<link href="http://ramblernewspapers.com/wp-content/themes/foodmagz/includes/css/colabs-css.css" rel="stylesheet" type="text/css" />  
<!-- Custom Favicon -->
<link rel="shortcut icon" href="http://ramblernewspapers.com/wp-content/uploads/2013/08/RN.com_.Header.gif"/>

<!-- CoLabs Shortcodes CSS -->
<link href="http://ramblernewspapers.com/wp-content/themes/backbone/functions/css/shortcodes.css" rel="stylesheet" type="text/css" />

<!-- Custom Stylesheet -->
<link href="http://ramblernewspapers.com/wp-content/uploads/foodmagz-custom/custom.css" rel="stylesheet" type="text/css" />
<!-- Start Shareaholic Analytics -->
<script type="text/javascript">
  (function() {
  var dgh = document.createElement("script"); dgh.type = "text/javascript";dgh.async = true;
  dgh.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'dtym7iokkjlif.cloudfront.net/dough/1.0/recipe.js';
  var s = document.getElementsByTagName("script")[0]; s.parentNode.insertBefore(dgh, s);
  })();
</script>
<!-- End Shareaholic Analytics -->
<link rel="dns-prefetch" href="//connect.facebook.net" />
<link rel="alternate" type="application/rss+xml" title="Rambler Newspapers &raquo; Feed" href="http://ramblernewspapers.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Rambler Newspapers &raquo; Comments Feed" href="http://ramblernewspapers.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Rambler Newspapers &raquo; iCal Feed" href="http://ramblernewspapers.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Rambler Newspapers &raquo; Luncheon turns lemons into lemonade Comments Feed" href="http://ramblernewspapers.com/2017/05/luncheon-turns-lemons-into-lemonade/feed/" />
<link rel='stylesheet' id='pmpro_frontend-css'  href='http://ramblernewspapers.com/wp-content/plugins/paid-memberships-pro/css/frontend.css?ver=1.8.4.2' type='text/css' media='screen' />
<link rel='stylesheet' id='pmpro_print-css'  href='http://ramblernewspapers.com/wp-content/plugins/paid-memberships-pro/css/print.css?ver=1.8.4.2' type='text/css' media='print' />
<link rel='stylesheet' id='advpsStyleSheet-css'  href='http://ramblernewspapers.com/wp-content/plugins/advanced-post-slider/advps-style.css?ver=4.1.17' type='text/css' media='all' />
<link rel='stylesheet' id='pptwj-widget-tab-css-css'  href='http://ramblernewspapers.com/wp-content/plugins/popular-posts-tab-widget-for-jetpack/tab.css?ver=4.1.17' type='text/css' media='all' />
<link rel='stylesheet' id='wptt_front-css'  href='http://ramblernewspapers.com/wp-content/plugins/wp-twitter-feeds/css/admin_style.min.css?ver=4.1.17' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_image_widget-css'  href='http://ramblernewspapers.com/wp-content/plugins/jetpack/modules/widgets/image-widget/style.css?ver=20140808' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='http://ramblernewspapers.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://ramblernewspapers.com/wp-content/plugins/jetpack/css/jetpack.css?ver=3.6' type='text/css' media='all' />
<script type='text/javascript' src='http://ramblernewspapers.com/wp-includes/js/jquery/jquery.js?ver=1.11.1'></script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.2.1'></script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-content/plugins/paid-memberships-pro/js/paid-memberships-pro.js?ver=4.1.17'></script>
<script type='text/javascript' src='http://cdn.embedly.com/widgets/platform.js?ver=4.1.17'></script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-content/plugins/advanced-post-slider/js/advps.frnt.script.js?ver=4.1.17'></script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-content/plugins/advanced-post-slider/bxslider/jquery.bxslider.min.js?ver=4.1.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var PPTWJ = {"ajaxUrl":"http:\/\/ramblernewspapers.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-content/plugins/popular-posts-tab-widget-for-jetpack/tab.js?ver=4.1.17'></script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-content/themes/foodmagz/includes/js/plugins.js?ver=4.1.17'></script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-content/themes/foodmagz/includes/js/scripts.js?ver=4.1.17'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://ramblernewspapers.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://ramblernewspapers.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Mark your calendar!' href='http://ramblernewspapers.com/2017/05/mark-your-calendar-2/' />
<meta name="generator" content="WordPress 4.1.17" />
<link rel='canonical' href='http://ramblernewspapers.com/2017/05/luncheon-turns-lemons-into-lemonade/' />
<link rel='shortlink' href='http://wp.me/p3vbfn-4yM' />
<!-- <meta name="NextGEN" version="2.1.62" /> -->

<!-- CoLabs Color Scheme -->
<style type="text/css">

</style>
<!-- /CoLabs Color Scheme -->


<!-- Theme version -->
<meta name="generator" content="FoodMagz 1.1.8" />
<meta name="generator" content="CoLabsFramework 1.8.6" />
	
	<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="http://ramblernewspapers.com/feed/" />
	<link rel="pingback" href="http://ramblernewspapers.com/xmlrpc.php" />
	<link rel="alternate" type="text/xml" title="RSS .92" href="http://ramblernewspapers.com/feed/rss/" />
	<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="http://ramblernewspapers.com/feed/atom/" />
<meta property="og:site_name" content="Rambler Newspapers" />
<meta property="og:type" content="article" />
<meta property="og:locale" content="en_US" />
<meta property="fb:app_id" content="477513062334887" />
<meta property="og:url" content="http://ramblernewspapers.com/2017/05/luncheon-turns-lemons-into-lemonade/" />
<meta property="og:title" content="Luncheon turns lemons into lemonade" />
<meta property="og:description" content="Thirty-one years ago, League of Volunteers member Bettye Davis began bringing slices of lemon cakes to council meetings. Every year since, Davis has been providing her prized cakes to help raise money for the community. So it was no surprise that this year&#039;s annual Soup,&hellip;" />
<meta property="og:image" content="http://ramblernewspapers.com/wp-content/uploads/2017/05/Salvation-Army-officers-edited.jpg" />
<meta property="og:image:width" content="4288" />
<meta property="og:image:height" content="2848" />
<meta property="article:published_time" content="2017-05-13T13:00:54+00:00" />
<meta property="article:modified_time" content="2017-05-12T16:57:29+00:00" />
<meta property="article:author" content="http://ramblernewspapers.com/author/joe-snell/" />
<meta property="article:section" content="Community Events" />
<meta property="article:tag" content="Featured Stories" />
<meta property="article:tag" content="Irving" />

<style id="custom-css-css">/*
Welcome to Custom CSS!

CSS (Cascading Style Sheets) is a kind of code that tells the browser how
to render a web page. You may delete these comments and get started with
your customizations.

By default, your stylesheet will be loaded after the theme stylesheets,
which means that your rules can take precedence and override the theme CSS
rules. Just write here what you want to change, you don't need to copy all
your theme's stylesheet content.
*/</style>
<link rel='stylesheet' id='embedly_font_end-css'  href='http://ramblernewspapers.com/wp-content/plugins/embedly/css/embedly-frontend.css?ver=4.1.17' type='text/css' media='all' />
</head>
<body class="single single-post postid-17532 single-format-standard three-col-left width-980 three-col-left-980 unknown">

<div class="container">
  <div class="row-main">

    <header class="top-section">
      <hgroup class="logo">
        <h1 class="site-title">
		<a href="http://ramblernewspapers.com/">
		<img src="http://ramblernewspapers.com/wp-content/uploads/2013/08/RN.com_.Header.gif" alt="Rambler Newspapers" />		</a></h1>
        <h2 class="site-tagline">Serving Irving, Las Colinas, Valley Ranch, Coppell and DFW International Airport</h2>
      </hgroup><!-- .logo -->

      <form class="search-box" action="">
        <input type="text" name="s" value="" placeholder="Search">
        <input type="submit" value="Search">
        		<p>

        </p>
		      </form><!-- .search-box -->
    </header><!-- .top-section -->



    <nav class="main-nav">
      <a class="btn-navbar collapsed">
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
        <span class="icon-bar"></span>
      </a>
      
      <div class="nav-collapse collapse">
        <div class=" megaWrapper"><ul id="menu-top-navigation" class="colabs_mega"><li id="menu-item-25" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children"><a href="http://ramblernewspapers.com/category/news/">News</a>


<ul class="sub-menu">
	<li id="menu-item-23" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children"><a href="http://ramblernewspapers.com/category/irving/">Irving</a>
	<ul class="sub-menu">
		<li id="menu-item-5530" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/irvingscholars/">Irving Scholars</a></li>
		<li id="menu-item-5534" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="http://ramblernewspapers.com/irving-isd-photo-gallery/">Irving ISD Photo Gallery</a></li>
	</ul>
</li>
	<li id="menu-item-22" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://ramblernewspapers.com/category/coppell/">Coppell</a>
	<ul class="sub-menu">
		<li id="menu-item-5531" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/coppellscholars/">Coppell Scholars</a></li>
	</ul>
</li>
	<li id="menu-item-1028" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/news/dfw-international/">DFW Area Aviation</a></li>
	<li id="menu-item-8792" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/news/contributed/">Contributed</a></li>
</ul>
</li>
<li id="menu-item-30" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children"><a href="http://ramblernewspapers.com/category/local/">Local</a>


<ul class="sub-menu">
	<li id="menu-item-1535" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent"><a href="http://ramblernewspapers.com/category/local/community-events/">Community Events</a></li>
</ul>
</li>
<li id="menu-item-11486" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/arts-entertainment/">Arts &#038; Entertainment</a></li>
<li id="menu-item-29" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/sports/">Sports</a></li>
<li id="menu-item-13655" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/home-health/">Home &#038; Health</a></li>
<li id="menu-item-28" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://ramblernewspapers.com/category/opinion/">Opinion</a>


<ul class="sub-menu">
	<li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/opinion/letters-to-the-editor/">Letters to the Editor</a></li>
</ul>
</li>
<li id="menu-item-7844" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children"><a href="http://ramblernewspapers.com/contact/">Contact</a>


<ul class="sub-menu">
	<li id="menu-item-9070" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://ramblernewspapers.com/contact/about-rambler-newspapers/">About Rambler Newspapers</a></li>
	<li id="menu-item-11209" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://ramblernewspapers.com/contact/careers/">Careers</a></li>
</ul>
</li>
<li id="menu-item-4298" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://ramblernewspapers.com/category/newspaper-archives/">Archives</a>


<ul class="sub-menu">
	<li id="menu-item-4305" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/">Irving Rambler</a>
	<ul class="sub-menu">
		<li id="menu-item-16496" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/2017/">2017</a></li>
		<li id="menu-item-14071" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/2016/">2016</a></li>
		<li id="menu-item-11312" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2015/">2015</a></li>
		<li id="menu-item-5062" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2014-irving-rambler-archive/">2014</a></li>
		<li id="menu-item-4307" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2013-irving-rambler-archive/">2013</a></li>
		<li id="menu-item-4306" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2012-irving-rambler-archive/">2012</a></li>
		<li id="menu-item-4324" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2011/">2011</a></li>
		<li id="menu-item-4323" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2010/">2010</a></li>
		<li id="menu-item-4322" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2009/">2009</a></li>
		<li id="menu-item-4321" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2008/">2008</a></li>
		<li id="menu-item-4320" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2007/">2007</a></li>
		<li id="menu-item-4319" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2006/">2006</a></li>
		<li id="menu-item-4318" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2005/">2005</a></li>
		<li id="menu-item-4317" class="menu-item menu-item-type-taxonomy menu-item-object-category"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2004/">2004</a></li>
	</ul>
</li>
</ul>
</li>
</ul></div>      </div>
    </nav><!-- .main-menu -->


    <div class="main-container">
      <div class="row">
<div class="innercontainer column col9">
			<div class="ads ads-top">
		<!-- Beginning PassBack for Ad unit BENN/Irving_Rambler ### size: [[728,90]] -->
<script type='text/javascript' src='http://www.googletagservices.com/tag/js/gpt.js'>
googletag.pubads().definePassback('6785150/BENN/Irving_Rambler', [[728,90]]).setTargeting('fold',['ATF']).display();
</script>
<!-- End Passback -->		</div><!-- .ads-top -->
	
    <div class="row">
		        <div class="post-17532 post type-post status-publish format-standard hentry category-community-events category-featured-stories category-irving content column three-col-left col5">
  				<div class="breadcrumb breadcrumbs colabs-breadcrumbs"><div class="breadcrumb-trail"><span class="trail-before"><span class="breadcrumb-title">You are here:</span></span> <a href="http://ramblernewspapers.com" title="Rambler Newspapers" rel="home" class="trail-begin">Home</a> <span class="sep">&raquo;</span> <span class="trail-end">Luncheon turns lemons into lemonade</span></div></div>  				  					<div class="entry-post">
		
		<h3 class="entry-title">Luncheon turns lemons into lemonade</h3>	<p class="entry-meta">
		<time class="entry-date">May 13, 2017</time> By <a href="http://ramblernewspapers.com/author/joe-snell/" title="Posts by Joe Snell" rel="author">Joe Snell</a> In <a href="http://ramblernewspapers.com/category/local/community-events/" rel="category tag">Community Events</a>, <a href="http://ramblernewspapers.com/category/news/featured-stories/" rel="category tag">Featured Stories</a>, <a href="http://ramblernewspapers.com/category/irving/" rel="category tag">Irving</a>	</p>
	<span class="comment-count">0</span>
					<div class="entry-top">
				<a title="Luncheon turns lemons into lemonade" href="http://ramblernewspapers.com/wp-content/uploads/2017/05/Salvation-Army-officers-edited.jpg" rel="lightbox"><img src="http://ramblernewspapers.com/wp-content/themes/backbone/functions/timthumb.php?src=wp-content/uploads/2017/05/Salvation-Army-officers-edited.jpg&amp;w=500&amp;h=&amp;zc=1&amp;q=90" alt="Luncheon turns lemons into lemonade" class="colabs-image"  /></a>			</div>
			
				<div class="entry-content">
			<p>Thirty-one years ago, League of Volunteers member Bettye Davis began bringing slices of lemon cakes to council meetings. Every year since, Davis has been providing her prized cakes to help raise money for the community.</p>
<p>So it was no surprise that this year&#8217;s annual Soup, Soap, and Hope Ladies&#8217; Luncheon, an event organized by The Salvation Army of Irving&#8217;s League of Volunteers, likened the Salvation Army&#8217;s work to turning lemons into lemonade.</p>
<p>“As we picture the work of the Salvation Army, we usually picture Christmas, and bell ringers. If you watch the Hallmark movies, you see them all of the time,” said Kay Heldman, volunteer with the League of Volunteers. “But in our own community, we have many people, adult and children, that have been dealt some lemons in their everyday lives. This is where our local unit is making lemonade.”</p>
<p>Funds raised at the event, which took place on April 4 and raised money through efforts like Bettye&#8217;s cakes as well as donations, will go toward sending children to summer camp.</p>
<p>Founded eight years ago by Bonnie Kelley, the League of Volunteers aids The Salvation Army with both its ministry and mission. Today, the group has 22 members that meet every month and assist the corps through events such as food distribution and funding camp scholarships.</p>
<p>“We hope to touch hearts,” said Debby Kruse, a volunteer with the organization. “We are here for the work of the Irving corps, to become involved and especially to raise money, so we can do more for the kids.”</p>
<p>Bonnie Kelley recognized Christina Winters-Gears, Chief Executive Officer and President of Creating and Managing Wealth, with a special certificate of appreciation.</p>
<p>“I&#8217;ve been supporting [The Salvation Army] for 20 years,” Winters-Gears said. “I started doing the Christmas Luncheon and that was 1993.”</p>
<p>Winters-Gears says that reaching out and initiating a conversation are the most important steps for anyone wanting to get involved in their own community.</p>
<p>“Start talking to people in your neighborhood or your church,” Winters-Gears said. “Talk to people and ask them what they doing or what&#8217;s happening.”</p>
<p>In honor of the late Merle Heldman, a volunteer who regularly contributed to the League of Volunteers, the organization contributed $5,000 to the Boys and Girls club for scholarships. Kelly also announced that a special venue would be named the Heldman Performance Hall on behalf of Merle and his wife Kay.</p>
<p>Each year, a League of Volunteers member is recognized for going above and beyond. This year, Becky Weaver was highlighted for her work arranging flowers every week, passing out food to the hungry, and offering help across multiple activities.</p>
<p>“If you don&#8217;t know about The Salvation Army, it&#8217;s the best secret we have here in Irving,” Weaver said. “Just get involved. There are a lot of things to do, and there&#8217;s a place for all of you. It&#8217;s a blessing.”</p>
<p>Charles Hanson was also presented a certificate for his work with the Boys and Girls Club, which will have 190 children participating this summer. For $40 per child, The Salvation Army takes children to places like Six Flags and AT&amp;T Stadium.</p>
<p>Lieutenants Benjamin and Charlsie Godwin, currently appointed to the Salvation Army Corps. in San Antonio, served as the event’s keynote speakers.</p>
<p>“The Salvation Army is a church and a social services agency,” Ben Godwin said. “Our mission is to preach the gospel of Jesus Christ and meet human needs in His name. Many people don&#8217;t know that we are a church; that&#8217;s why we&#8217;re doing all of this. We&#8217;re motivated by the love of Jesus to help others in our community and help those who maybe don&#8217;t have the same resources that we do.”</p>
<p>Kruse reiterated the constant support The Salvation Army provides for the community.</p>
<p>“There are people out there that don&#8217;t have any other options,” she said. “They can&#8217;t afford to put food on the table, and they don&#8217;t have a place to go where they can get help. The Salvation Army opens their doors to everyone.”</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-17532" class="share-facebook sd-button share-icon" href="http://ramblernewspapers.com/2017/05/luncheon-turns-lemons-into-lemonade/?share=facebook" target="_blank" title="Share on Facebook"><span>Facebook</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon" href="http://ramblernewspapers.com/2017/05/luncheon-turns-lemons-into-lemonade/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon" href="http://ramblernewspapers.com/2017/05/luncheon-turns-lemons-into-lemonade/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div>		</div>
		<div class="social_share"><div class="colabs-sc-twitter left"><a href="http://twitter.com/share" class="twitter-share-button" data-url="http://ramblernewspapers.com/2017/05/luncheon-turns-lemons-into-lemonade/" data-via="ramblerupdate"data-count="horizontal" data-count="horizontal">Tweet</a><script type="text/javascript" src="http://platform.twitter.com/widgets.js"></script></div>
<div class="colabs-fblike fl">
<iframe src="http://www.facebook.com/plugins/like.php?href=http://ramblernewspapers.com/2017/05/luncheon-turns-lemons-into-lemonade/&amp;layout=button_count&amp;show_faces=false&amp;width=85&amp;action=like&amp;colorscheme=light&amp;font=arial" scrolling="no" frameborder="0" allowTransparency="true" style="border:none; overflow:hidden; width:85px; height:30px;"></iframe>
</div>
	<div class="clear"></div></div>				<p class="entry-info"></p>
<div class="entry-author">
	<span class="profile-image"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/12/image1-640x799-150x187.jpg" width="44" height="55" alt="Joe Snell" class="avatar avatar-55 wp-user-avatar wp-user-avatar-55 alignnone photo" /></span>
	<div class="profile-content author-detail">
		<h3>About <a href="http://ramblernewspapers.com/author/joe-snell/">Joe Snell</a></h3>
        <p>Joe Snell studied film and business law at the University of Southern California. He has worked for a number of film and television companies including 21st Century Fox, Starz Entertainment, Creative Artists Agency, and Brillstein Entertainment Partners.		        <a href="http://ramblernewspapers.com/author/joe-snell/">
				View all posts by Joe Snell <span class="meta-nav">&rarr;</span>			</a>
		</p>
			</div>
	<div class="clear"></div>
</div><!--/.entry-author-->
	        <div id="page-top" class="post-entries">
	            <div class="page-prev fl"><a href="http://ramblernewspapers.com/2017/05/mark-your-calendar-2/" rel="prev"><span class="meta-nav">&larr;</span> Mark your calendar!</a></div>
	            <div class="page-next fr"></div>
	            <div class="clear"></div>
	        </div><!--/#page-top-->
	
			</div>



<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<div class="fb-social-plugin comment-form fb-comments" id="commentform" data-href="http://ramblernewspapers.com/2017/05/luncheon-turns-lemons-into-lemonade/" data-width="462" data-order-by="social"></div>
</div></div>
  									  
  					
        </div><!-- .content -->
		 
		<div id="sidebar-second" class="sidebar sidebar-right column col4">
			<div id="colabs_subscribe-2" class="widget widget_colabs_subscribe">        <h4 class="widget-title">        Sign up for Rambler email updates!		</h4>        
	   <form class="feedemail-form" action="http://feedburner.google.com/fb/a/mailverify" method="post" target="popupwindow" onsubmit="window.open('http://feedburner.google.com/fb/a/mailverify?uri=', 'popupwindow', 'scrollbars=no,width=100,height=200');return true">
		<input type="text" class="feedemail-input" name="email" placeholder="Your Email Here"/>
		<input type="hidden" value="" name="uri"/>
		<input type="hidden" name="loc" value="en_US"/>
		<input type="submit" value="Signup" class="feedemail-button"/>
		<div><span class="feedemail-footer">Delivered by <a href="http://feedburner.google.com" target="_blank">FeedBurner</a></span></div>
	   </form>        
        
		</div>   
   <div id="image-7" class="widget widget_image"><div class="jetpack-image-container"><a href="http://www.christianscienceirving.com/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/FCCSedit2.jpg" class="alignnone" width="640" height="272" /></a></div>
</div><div id="image-2" class="widget widget_image"><div class="jetpack-image-container"><a href="http://www.chateauonwildbriarlake.com/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/5191-800x450.jpg" class="aligncenter" width="431" height="604" /></a></div>
</div><div id="image-9" class="widget widget_image"><div class="jetpack-image-container"><a href="https://www.facebook.com/Betcha-Bingo-813975168680884/?rf=188739101162941"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/BETCHA-LOGO-1024x87.jpg" class="alignnone" /></a></div>
</div><div id="wptt_twittertweets-2" class="widget wptt_TwitterTweets"><h4 class="widget-title">Latest Tweets</h4>			

<ul class="fetched_tweets light">
						    			        <li class="tweets_avatar">
			        	<div class="tweet_wrap"><div class="wdtf-user-card ltr"><div class="clear"></div></div>			       		<div class="tweet_data">
			        	Irving geocaching event inspires urban exploration | <a href="https://t.co/jgA81uNBwg" target="_blank" rel="nofollow">https://t.co/jgA81uNBwg</a> <a href="https://t.co/sIEHqn95Zb" target="_blank" rel="nofollow">https://t.co/sIEHqn95Zb</a>			        	</div>
			            <br/>
			            <div class="clear"></div>
			            <div class="times">
			            <em>
			            
						<a href="http://www.twitter.com/DFW_Rambler" target="_blank" title="Follow Rambler Newspapers on Twitter [Opens new window]">
							1d							</a>
			            </em>
			            </div>
												<div class="clear"></div>
</div><div class="clear"></div>
			        </li>
			    
						</ul>
			
			</div><div id="image-5" class="widget widget_image"><div class="jetpack-image-container"><a href="http://www.unitychurchofirving.com/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/5185.png" class="alignnone" width="1024" height="512" /></a></div>
</div>	
			<div id="pptwj-2" class="widget pptwj">
			
			<div class="pptwj-tabs-wrap">
	
				<ul class="tab-links">
										
					<li class="popular"><a href="#tab-pop">Popular</a></li>										<li class="latest"><a href="#tab-latest">Latest</a></li>				</ul>
				
				<div class="clear"></div>
	
				<div class="boxes box inside">
	
						
										<div id="tab-pop">
						<ul class="tab-filter-list" data-type="popular">
							<li>
																	<a href="#" data-time="day" data-numberposts="10" data-thumb="3" data-tab="popular">Today</a>
																	<a href="#" data-time="week" data-numberposts="10" data-thumb="3" data-tab="popular">Week</a>
																	<a href="#" data-time="month" data-numberposts="10" data-thumb="3" data-tab="popular">Month</a>
																	<a href="#" data-time="all" data-numberposts="10" data-thumb="3" data-tab="popular">All</a>
															</li>
						</ul>
						<ul class="list">
									<li class="odd">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/03/texas-legislators-file-granny-tax-bill-to-fill-state-budget-hole/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/03/N0551300-889x695-150x117.jpg" alt="Texas legislators file ‘Granny Tax’ bill to fill state budget hole" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Texas legislators file ‘Granny Tax’ bill to fill state budget hole" href="http://ramblernewspapers.com/2017/03/texas-legislators-file-granny-tax-bill-to-fill-state-budget-hole/">Texas legislators file ‘Granny Tax’ bill to fill state budget hole</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="even">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/03/the-price-was-right-for-irving-resident/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/03/7874K-DEMESHIA-VALDEZ-1-1024x576-150x84.jpg" alt="The Price was right for Irving resident" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="The Price was right for Irving resident" href="http://ramblernewspapers.com/2017/03/the-price-was-right-for-irving-resident/">The Price was right for Irving resident</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="odd">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/04/rambler-04-15-2017/"><img src="http://ramblernewspapers.com/wp-content/plugins/popular-posts-tab-widget-for-jetpack/default.png" alt="Rambler 04-15-2017" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Rambler 04-15-2017" href="http://ramblernewspapers.com/2017/04/rambler-04-15-2017/">Rambler 04-15-2017</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="even">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/04/irving-isd-celebrates-career-and-technical-education-program/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/04/Irving-ISD-celebrates-online-edited-150x100.jpg" alt="Irving ISD celebrates Career and Technical Education program" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Irving ISD celebrates Career and Technical Education program" href="http://ramblernewspapers.com/2017/04/irving-isd-celebrates-career-and-technical-education-program/">Irving ISD celebrates Career and Technical Education program</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="odd">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/04/rambler-04-22-2017-2/"><img src="http://ramblernewspapers.com/wp-content/plugins/popular-posts-tab-widget-for-jetpack/default.png" alt="Rambler 04-22-2017" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Rambler 04-22-2017" href="http://ramblernewspapers.com/2017/04/rambler-04-22-2017-2/">Rambler 04-22-2017</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="even">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/04/irving-isd-rejects-safe-zone-for-learning/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/04/Irving-ISD-rejects-150x100.jpg" alt="Irving ISD rejects “safe zone for learning”" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Irving ISD rejects “safe zone for learning”" href="http://ramblernewspapers.com/2017/04/irving-isd-rejects-safe-zone-for-learning/">Irving ISD rejects “safe zone for learning”</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="odd">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/04/irving-based-bank-among-best-companies-to-work-for-in-texas/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/04/Bank-online-edited-150x100.jpg" alt="Irving-based bank among best companies to work for in Texas" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Irving-based bank among best companies to work for in Texas" href="http://ramblernewspapers.com/2017/04/irving-based-bank-among-best-companies-to-work-for-in-texas/">Irving-based bank among best companies to work for in Texas</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="even">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/02/texas-workforce-commission-presents-grant-for-job-training/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/02/N1309P26010C-1020x574-150x84.jpg" alt="Texas Workforce Commission presents grant for job training" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Texas Workforce Commission presents grant for job training" href="http://ramblernewspapers.com/2017/02/texas-workforce-commission-presents-grant-for-job-training/">Texas Workforce Commission presents grant for job training</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="odd">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/04/irving-isd-athletic-hall-of-fame-names-inductees/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/04/Irving-ISD-Athletic-Hall-of-Fame-150x100.jpg" alt="Irving ISD Athletic Hall of Fame names inductees" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Irving ISD Athletic Hall of Fame names inductees" href="http://ramblernewspapers.com/2017/04/irving-isd-athletic-hall-of-fame-names-inductees/">Irving ISD Athletic Hall of Fame names inductees</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="even">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/04/irving-affected-by-national-immigration-orders/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/04/Immigration-online-edited-150x100.jpg" alt="Irving affected by national immigration orders" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Irving affected by national immigration orders" href="http://ramblernewspapers.com/2017/04/irving-affected-by-national-immigration-orders/">Irving affected by national immigration orders</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
								</ul>
					</div><!-- #tab-pop -->
															<div id="tab-latest">
						<ul class="list">
										<li class="odd">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/05/luncheon-turns-lemons-into-lemonade/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/05/Salvation-Army-officers-edited-150x100.jpg" alt="Luncheon turns lemons into lemonade" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Luncheon turns lemons into lemonade" href="http://ramblernewspapers.com/2017/05/luncheon-turns-lemons-into-lemonade/">Luncheon turns lemons into lemonade</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="even">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/05/mark-your-calendar-2/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/05/Calendar-150x100.jpg" alt="Mark your calendar!" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Mark your calendar!" href="http://ramblernewspapers.com/2017/05/mark-your-calendar-2/">Mark your calendar!</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="odd">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/05/irving-geocaching-event-inspires-urban-exploration/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/05/Geocaching-edited-150x100.jpg" alt="Irving geocaching event inspires urban exploration" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Irving geocaching event inspires urban exploration" href="http://ramblernewspapers.com/2017/05/irving-geocaching-event-inspires-urban-exploration/">Irving geocaching event inspires urban exploration</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="even">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/05/canal-fest-invites-international-cultures-to-irving/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/05/DSC_3030-150x100.jpg" alt="Canal Fest invites international cultures to Irving" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Canal Fest invites international cultures to Irving" href="http://ramblernewspapers.com/2017/05/canal-fest-invites-international-cultures-to-irving/">Canal Fest invites international cultures to Irving</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="odd">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/05/irving-hosts-jrotc-national-drill-championship/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/05/JROTC-edited-online-3-150x103.jpg" alt="Irving hosts JROTC National Drill Championship" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Irving hosts JROTC National Drill Championship" href="http://ramblernewspapers.com/2017/05/irving-hosts-jrotc-national-drill-championship/">Irving hosts JROTC National Drill Championship</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="even">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/05/north-lake-immigration-panel-educates-reassures-community/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/05/North-Lake-College-Logo-150x105.jpg" alt="North Lake immigration panel educates, reassures community" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="North Lake immigration panel educates, reassures community" href="http://ramblernewspapers.com/2017/05/north-lake-immigration-panel-educates-reassures-community/">North Lake immigration panel educates, reassures community</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="odd">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/05/rambler-05-06-2017/"><img src="http://ramblernewspapers.com/wp-content/plugins/popular-posts-tab-widget-for-jetpack/default.png" alt="Rambler 05-06-2017" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Rambler 05-06-2017" href="http://ramblernewspapers.com/2017/05/rambler-05-06-2017/">Rambler 05-06-2017</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="even">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/05/annual-trash-off-brings-out-irvings-community-spirit/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/05/Trash-Off-edited-150x116.jpg" alt="Annual Trash Off brings out Irving’s community spirit" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Annual Trash Off brings out Irving’s community spirit" href="http://ramblernewspapers.com/2017/05/annual-trash-off-brings-out-irvings-community-spirit/">Annual Trash Off brings out Irving’s community spirit</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="odd">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/05/make-plans-this-weekend/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/05/Calendar-Ice-Cream-2-150x100.jpg" alt="Make plans this weekend!" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Make plans this weekend!" href="http://ramblernewspapers.com/2017/05/make-plans-this-weekend/">Make plans this weekend!</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="even">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/05/charlottes-web-snares-south-irving-library/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/05/Charlottes-Web-edited-150x100.jpg" alt="Charlotte’s Web snares South Irving Library" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Charlotte’s Web snares South Irving Library" href="http://ramblernewspapers.com/2017/05/charlottes-web-snares-south-irving-library/">Charlotte’s Web snares South Irving Library</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
								</ul>
					</div><!-- #tab-latest -->
															<div class="pptwj-loader"><img src="http://ramblernewspapers.com/wp-includes//images/wpspin-2x.gif" alt="Ajax spinner"></div>
				</div><!-- /.boxes -->
			</div><!-- /pptwj-tabs-wrap -->

			</div>			<div id="categories-2" class="widget widget_categories"><h4 class="widget-title">Find what you&#8217;re looking for? Browse News by Category</h4><select name='cat' id='cat' class='postform' >
	<option value='-1'>Select Category</option>
	<option class="level-0" value="177">2004</option>
	<option class="level-0" value="176">2005</option>
	<option class="level-0" value="175">2006</option>
	<option class="level-0" value="174">2007</option>
	<option class="level-0" value="173">2008</option>
	<option class="level-0" value="172">2009</option>
	<option class="level-0" value="171">2010</option>
	<option class="level-0" value="170">2011</option>
	<option class="level-0" value="189">2011</option>
	<option class="level-0" value="163">2012</option>
	<option class="level-0" value="165">2012</option>
	<option class="level-0" value="167">2012</option>
	<option class="level-0" value="164">2013</option>
	<option class="level-0" value="166">2013</option>
	<option class="level-0" value="168">2013</option>
	<option class="level-0" value="185">2014</option>
	<option class="level-0" value="183">2014</option>
	<option class="level-0" value="184">2014</option>
	<option class="level-0" value="214">2015</option>
	<option class="level-0" value="220">2016</option>
	<option class="level-0" value="221">2017</option>
	<option class="level-0" value="154">Archives</option>
	<option class="level-0" value="19">Arlington</option>
	<option class="level-0" value="216">Arts &amp; Entertainment</option>
	<option class="level-0" value="24">Church Directory</option>
	<option class="level-0" value="144">Community Events</option>
	<option class="level-0" value="186">Contributed</option>
	<option class="level-0" value="4">Coppell</option>
	<option class="level-0" value="161">Coppell Rambler</option>
	<option class="level-0" value="148">Coppell Scholars</option>
	<option class="level-0" value="191">Correction</option>
	<option class="level-0" value="25">Dallas</option>
	<option class="level-0" value="218">DFW Area Aviation</option>
	<option class="level-0" value="26">DFW International</option>
	<option class="level-0" value="162">DFW News Flash</option>
	<option class="level-0" value="27">Editorials</option>
	<option class="level-0" value="5">Entertainment</option>
	<option class="level-0" value="22">Featured Stories</option>
	<option class="level-0" value="6">Features</option>
	<option class="level-0" value="28">Flower Mound</option>
	<option class="level-0" value="187">Fort Worth</option>
	<option class="level-0" value="29">Grand Prarie</option>
	<option class="level-0" value="30">Grapevine</option>
	<option class="level-0" value="31">Guest Columns</option>
	<option class="level-0" value="219">Home &amp; Health</option>
	<option class="level-0" value="9">Irving</option>
	<option class="level-0" value="160">Irving Rambler</option>
	<option class="level-0" value="147">Irving Scholars</option>
	<option class="level-0" value="217">Jobs</option>
	<option class="level-0" value="32">Las Colinas</option>
	<option class="level-0" value="33">Letters to the Editor</option>
	<option class="level-0" value="34">Lewisville</option>
	<option class="level-0" value="10">Lifestyle</option>
	<option class="level-0" value="3">Local</option>
	<option class="level-0" value="35">Local News</option>
	<option class="level-0" value="11">News</option>
	<option class="level-0" value="159">Newspaper Archives</option>
	<option class="level-0" value="12">Obituaries</option>
	<option class="level-0" value="13">Opinion</option>
	<option class="level-0" value="14">Reader&#8217;s Choice</option>
	<option class="level-0" value="15">Service Organizations</option>
	<option class="level-0" value="16">South Lake</option>
	<option class="level-0" value="17">Sports</option>
	<option class="level-0" value="149">Texas Wild</option>
	<option class="level-0" value="188">This week</option>
	<option class="level-0" value="1">Uncategorized</option>
	<option class="level-0" value="18">Valley Ranch</option>
	<option class="level-0" value="145">Volunteer Opportunities</option>
</select>

<script type='text/javascript'>
/* <![CDATA[ */
	var dropdown = document.getElementById("cat");
	function onCatChange() {
		if ( dropdown.options[dropdown.selectedIndex].value > 0 ) {
			location.href = "http://ramblernewspapers.com/?cat="+dropdown.options[dropdown.selectedIndex].value;
		}
	}
	dropdown.onchange = onCatChange;
/* ]]> */
</script>

</div><div id="image-3" class="widget widget_image"><div class="jetpack-image-container"><a href="https://www.statefarm.com/agent/US/TX/Irving/Bill-Hooten-4XDNY1YS000"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/Hooten-High-Quality-1024x170.jpg" class="alignnone" width="1024" height="170" /></a></div>
</div><div id="image-13" class="widget widget_image"><div class="jetpack-image-container"><a href="http://www.beltlinechurch.com/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/5227-800x188.jpg" class="alignnone" /></a></div>
</div><div id="image-4" class="widget widget_image"><div class="jetpack-image-container"><a href="http://verde.tech/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/verdelogo-2-800x196.jpg" class="alignnone" width="800" height="196" /></a></div>
</div><div id="image-14" class="widget widget_image"><div class="jetpack-image-container"><a target="_blank" href="https://www.facebook.com/pages/Shady-Grove-Cme-Church/111734895534160"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/04/Shady-Grove-Herschel-Walker-Flyer-edited.jpg" class="aligncenter" width="2353" height="2000" /></a></div>
</div></div><!-- /#sidebar-alt -->
    </div>
</div>
	  
<div class="sidebar sidebar-left col3 column">
	<div id="text-4" class="widget widget_text">			<div class="textwidget"><a href="https://twitter.com/DFW_Rambler" onclick="__gaTracker('send', 'event', 'outbound-widget', 'https://twitter.com/DFW_Rambler', 'Follow @DFW_Rambler');" class="twitter-follow-button" data-show-count="false">Follow @DFW_Rambler</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script></div>
		</div><div id="colabs_facebook-2" class="widget widget_colabs_facebook"><h4 class="widget-title">Facebook</h4>		<div class="pad5"></div>
        <iframe src="http://www.facebook.com/plugins/likebox.php?id=538080699554409&amp;connections=12&amp;stream=false&amp;header=true&amp;width=260&amp;height=140" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:260px; height:140px;" allowTransparency="true"></iframe>
		<div class="pad5"></div>
        </div><div id="colabs_postcat-3" class="widget widget_colabs_postcat">	
			<h4 class="widget-title">Current editions</h4>			<ul>
								<li>
										<p><a href="http://ramblernewspapers.com/2017/05/rambler-05-06-2017/">Rambler 05-06-2017</a></p>
				</li>	
								<li>
										<p><a href="http://ramblernewspapers.com/2017/05/rambler-04-29-2017/">Rambler 04-29-2017</a></p>
				</li>	
							</ul>
          			
        </div><div id="image-12" class="widget widget_image"><div class="jetpack-image-container"><a href="https://www.ppumc.org/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/ppumc-609x324.jpg" class="alignnone" /></a></div>
</div><div id="image-6" class="widget widget_image"><div class="jetpack-image-container"><a href="http://irvinghcc.com/home/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/Logo-Color-horse-for-chamber-Copy-1024x512.jpg" class="alignnone" /></a></div>
</div><div id="image-11" class="widget widget_image"><div class="jetpack-image-container"><a href="https://www.expresspros.com/IrvingTX/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/exp-emp-1024x320.jpg" class="alignnone" /></a></div>
</div><div id="colabs_postcat-2" class="widget widget_colabs_postcat">	
			<h4 class="widget-title">STORIES: REGIONAL AND STATEWIDE</h4>			<ul>
								<li>
					<a title="Irving affected by national immigration orders" href="http://ramblernewspapers.com/2017/04/irving-affected-by-national-immigration-orders/" ><img src="http://ramblernewspapers.com/wp-content/themes/backbone/functions/timthumb.php?src=wp-content/uploads/2017/04/Immigration-online-edited.jpg&amp;w=138&amp;h=100&amp;zc=1&amp;q=90&amp;a=c" alt="Irving affected by national immigration orders" class="colabs-image"  /></a>					<p><a href="http://ramblernewspapers.com/2017/04/irving-affected-by-national-immigration-orders/">Irving affected by national immigration orders</a></p>
				</li>	
								<li>
					<a title="Irving-based bank among best companies to work for in Texas" href="http://ramblernewspapers.com/2017/04/irving-based-bank-among-best-companies-to-work-for-in-texas/" ><img src="http://ramblernewspapers.com/wp-content/themes/backbone/functions/timthumb.php?src=wp-content/uploads/2017/04/Bank-online-edited.jpg&amp;w=138&amp;h=100&amp;zc=1&amp;q=90&amp;a=c" alt="Irving-based bank among best companies to work for in Texas" class="colabs-image"  /></a>					<p><a href="http://ramblernewspapers.com/2017/04/irving-based-bank-among-best-companies-to-work-for-in-texas/">Irving-based bank among best companies to work for in Texas</a></p>
				</li>	
								<li>
					<a title="Car care clinics to address check engine light" href="http://ramblernewspapers.com/2017/04/car-care-clinics-to-address-check-engine-light/" ><img src="http://ramblernewspapers.com/wp-content/themes/backbone/functions/timthumb.php?src=wp-content/uploads/2017/04/Car-Clinic.jpg&amp;w=138&amp;h=100&amp;zc=1&amp;q=90&amp;a=c" alt="Car care clinics to address check engine light" class="colabs-image"  /></a>					<p><a href="http://ramblernewspapers.com/2017/04/car-care-clinics-to-address-check-engine-light/">Car care clinics to address check engine light</a></p>
				</li>	
								<li>
					<a title="Project remembers World War I, marks anniversary of America’s entry" href="http://ramblernewspapers.com/2017/04/project-remembers-world-war-i-marks-anniversary-of-americas-entry/" ><img src="http://ramblernewspapers.com/wp-content/themes/backbone/functions/timthumb.php?src=wp-content/uploads/2017/04/WWI-Memorial.jpg&amp;w=138&amp;h=100&amp;zc=1&amp;q=90" alt="Project remembers World War I, marks anniversary of America’s entry" class="colabs-image"  /></a>					<p><a href="http://ramblernewspapers.com/2017/04/project-remembers-world-war-i-marks-anniversary-of-americas-entry/">Project remembers World War I, marks anniversary of America’s entry</a></p>
				</li>	
								<li>
					<a title="Celebrate National Arbor Day with free shade trees" href="http://ramblernewspapers.com/2017/04/celebrate-national-arbor-day-with-free-shade-trees/" ><img src="http://ramblernewspapers.com/wp-content/themes/backbone/functions/timthumb.php?src=wp-content/uploads/2017/04/N1409P69006C-1024x683.jpg&amp;w=138&amp;h=100&amp;zc=1&amp;q=90" alt="Celebrate National Arbor Day with free shade trees" class="colabs-image"  /></a>					<p><a href="http://ramblernewspapers.com/2017/04/celebrate-national-arbor-day-with-free-shade-trees/">Celebrate National Arbor Day with free shade trees</a></p>
				</li>	
								<li>
					<a title="Stop the raid on Texas schoolbook funds" href="http://ramblernewspapers.com/2017/04/stop-the-raid-on-texas-schoolbook-funds/" ><img src="http://ramblernewspapers.com/wp-content/themes/backbone/functions/timthumb.php?src=wp-content/uploads/2017/04/N1703P34002C-1024x683.jpg&amp;w=138&amp;h=100&amp;zc=1&amp;q=90" alt="Stop the raid on Texas schoolbook funds" class="colabs-image"  /></a>					<p><a href="http://ramblernewspapers.com/2017/04/stop-the-raid-on-texas-schoolbook-funds/">Stop the raid on Texas schoolbook funds</a></p>
				</li>	
								<li>
					<a title="Texas legislators file ‘Granny Tax’ bill to fill state budget hole" href="http://ramblernewspapers.com/2017/03/texas-legislators-file-granny-tax-bill-to-fill-state-budget-hole/" ><img src="http://ramblernewspapers.com/wp-content/themes/backbone/functions/timthumb.php?src=wp-content/uploads/2017/03/N0551300-889x695.jpg&amp;w=138&amp;h=100&amp;zc=1&amp;q=90&amp;a=t" alt="Texas legislators file ‘Granny Tax’ bill to fill state budget hole" class="colabs-image"  /></a>					<p><a href="http://ramblernewspapers.com/2017/03/texas-legislators-file-granny-tax-bill-to-fill-state-budget-hole/">Texas legislators file ‘Granny Tax’ bill to fill state budget hole</a></p>
				</li>	
								<li>
					<a title="“Be a First Responder” campaign tackles Dallas’ stray dog problem" href="http://ramblernewspapers.com/2017/03/be-a-first-responder-campaign-tackles-dallas-stray-dog-problem/" ><img src="http://ramblernewspapers.com/wp-content/themes/backbone/functions/timthumb.php?src=wp-content/uploads/2017/03/DSC_1928-1024x785.jpg&amp;w=138&amp;h=100&amp;zc=1&amp;q=90&amp;a=t" alt="“Be a First Responder” campaign tackles Dallas’ stray dog problem" class="colabs-image"  /></a>					<p><a href="http://ramblernewspapers.com/2017/03/be-a-first-responder-campaign-tackles-dallas-stray-dog-problem/">“Be a First Responder” campaign tackles Dallas’ stray dog problem</a></p>
				</li>	
								<li>
					<a title="Mistakes on your tax return could lead to an audit" href="http://ramblernewspapers.com/2017/03/mistakes-on-your-tax-return-could-lead-to-an-audit/" ><img src="http://ramblernewspapers.com/wp-content/themes/backbone/functions/timthumb.php?src=wp-content/uploads/2017/03/N1503P39008C-2-1020x680.jpg&amp;w=138&amp;h=100&amp;zc=1&amp;q=90" alt="Mistakes on your tax return could lead to an audit" class="colabs-image"  /></a>					<p><a href="http://ramblernewspapers.com/2017/03/mistakes-on-your-tax-return-could-lead-to-an-audit/">Mistakes on your tax return could lead to an audit</a></p>
				</li>	
								<li>
					<a title="Bark scale study reveals treatments to fight pest" href="http://ramblernewspapers.com/2017/03/bark-scale-study-reveals-treatments-to-fight-pest/" ><img src="http://ramblernewspapers.com/wp-content/themes/backbone/functions/timthumb.php?src=wp-content/uploads/2017/03/DSC_0086-1024x706.jpg&amp;w=138&amp;h=100&amp;zc=1&amp;q=90" alt="Bark scale study reveals treatments to fight pest" class="colabs-image"  /></a>					<p><a href="http://ramblernewspapers.com/2017/03/bark-scale-study-reveals-treatments-to-fight-pest/">Bark scale study reveals treatments to fight pest</a></p>
				</li>	
							</ul>
          			
        </div>
<!-- Start - HTML Javascript Adder plugin v3.9 -->
<div id="html_javascript_adder-4" class="widget widget_html_javascript_adder">
<div class="hjawidget textwidget">
<!-- Beginning PassBack for Ad unit BENN/Irving_Rambler ### size: [[160,600]] -->
<script type='text/javascript' src='http://www.googletagservices.com/tag/js/gpt.js'>
googletag.pubads().definePassback('6785150/BENN/Irving_Rambler', [[160,600]]).setTargeting('fold',['ATF']).display();
</script>
<!-- End Passback -->
</div>
</div><!-- End - HTML Javascript Adder plugin v3.9 -->
</div><!-- /#sidebar -->
		</div><!-- .row -->
	</div><!-- .main-container -->


    <footer class="footer">
      <h4 class="logo-footer"><a href="http://ramblernewspapers.com/">Rambler Newspapers</a></h4>

      <p class="copyright"><!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WJ36PN"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-WJ36PN');</script>
<!-- End Google Tag Manager --></p>

      <nav class="footer-nav">
        <div class="n megaWrapper"><ul id="menu-bottom-navigation" class="colabs_mega"><li id="menu-item-17" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="http://www.ramblernewspapers.com">Home</a></li>
<li id="menu-item-1064" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://ramblernewspapers.com/contact/about-rambler-newspapers/">About</a></li>
<li id="menu-item-2287" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://ramblernewspapers.com/legal/">Privacy Policy &#038; Terms of Service</a></li>
<li id="menu-item-1063" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://ramblernewspapers.com/contact/">Contact</a></li>
<li id="menu-item-1062" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="http://ramblernewspapers.com/subscribe/">Subscribe</a></li>
</ul></div>      </nav><!-- .footer-nav -->
    </footer><!-- .footer -->

  </div><!-- .row-main -->
</div>
<!-- .container -->

<!-- ngg_resource_manager_marker --><script type='text/javascript' src='http://ramblernewspapers.com/wp-includes/js/comment-reply.min.js?ver=4.1.17'></script>
<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201719'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Mayaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.1.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var FB_WP=FB_WP||{};FB_WP.queue={_methods:[],flushed:false,add:function(fn){FB_WP.queue.flushed?fn():FB_WP.queue._methods.push(fn)},flush:function(){for(var fn;fn=FB_WP.queue._methods.shift();){fn()}FB_WP.queue.flushed=true}};window.fbAsyncInit=function(){FB.init({"xfbml":true,"appId":"477513062334887"});if(FB_WP && FB_WP.queue && FB_WP.queue.flush){FB_WP.queue.flush()}}
/* ]]> */
</script>
<script type="text/javascript">(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id)){return}js=d.createElement(s);js.id=id;js.src="http:\/\/connect.facebook.net\/en_US\/all.js";fjs.parentNode.insertBefore(js,fjs)}(document,"script","facebook-jssdk"));</script>
		<!-- Memberships powered by Paid Memberships Pro v1.8.4.2.
 -->
		<!-- Powered by WPtouch: 3.8.1 -->	<div style="display:none">
	<div class="grofile-hash-map-2aa10e901b8d3d8e791c388742092704">
	</div>
	</div>
		<script type="text/javascript">
			!function(d,s,id){
				var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';
				if(!d.getElementById(id)){
					js=d.createElement(s);
					js.id=id;js.src=p+"://platform.twitter.com/widgets.js";
					fjs.parentNode.insertBefore(js,fjs);
				}
			}(document,"script","twitter-wjs");
		</script>
				<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
			<div id="sharing_email" style="display: none;">
		<form action="/2017/05/luncheon-turns-lemons-into-lemonade/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
			<script> document.getElementById('jetpack-source_f_name').value = ''; </script>
			
			<img style="float: right; display: none" class="loading" src="http://ramblernewspapers.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<script type='text/javascript' src='http://stats.wp.com/e-201719.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:3.6',blog:'51760413',post:'17532',tz:'-5',srv:'ramblernewspapers.com'} ]);
	_stq.push([ 'clickTrackerInit', '51760413', '17532' ]);
</script>
<div id="fb-root"></div> 


<!-- Native Ad Widget -->
<script type="text/javascript" src="http://code.jquery.com/jquery-1.7.1.min.js"></script>							
<script type="text/javascript" src="http://s3.amazonaws.com/ramblernewspapers/ramblernewspapers.js"></script>

</body>
</html>