<!DOCTYPE html>
<!--[if IE 7]>
<html class="ie ie7" lang="en-US">
<![endif]-->
<!--[if IE 8]>
<html class="ie ie8" lang="en-US">
<![endif]-->
<!--[if !(IE 7) & !(IE 8)]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
	<meta charset="UTF-8">
	<meta name="viewport" content="width=device-width">
	<title>Mark your calendar! | </title>
	<link rel="profile" href="http://gmpg.org/xfn/11">
	<link rel="pingback" href="http://ramblernewspapers.com/xmlrpc.php">
	<!--[if lt IE 9]>
	<script src="http://ramblernewspapers.com/wp-content/themes/twentyfourteen/js/html5.js"></script>
	<![endif]-->
	<link rel="dns-prefetch" href="//connect.facebook.net">
<link rel='dns-prefetch' href='//cdn.embedly.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s.gravatar.com' />
<link rel='dns-prefetch' href='//connect.facebook.net' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Feed" href="http://ramblernewspapers.com/feed/" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Comments Feed" href="http://ramblernewspapers.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title=" &raquo; iCal Feed" href="http://ramblernewspapers.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title=" &raquo; Mark your calendar! Comments Feed" href="http://ramblernewspapers.com/2017/07/mark-your-calendar-6/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/ramblernewspapers.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='pmpro_frontend-css'  href='http://ramblernewspapers.com/wp-content/plugins/paid-memberships-pro/css/frontend.css?ver=1.9.3' type='text/css' media='screen' />
<link rel='stylesheet' id='pmpro_print-css'  href='http://ramblernewspapers.com/wp-content/plugins/paid-memberships-pro/css/print.css?ver=1.9.3' type='text/css' media='print' />
<link rel='stylesheet' id='twentyfourteen-jetpack-css'  href='http://ramblernewspapers.com/wp-content/plugins/jetpack/modules/theme-tools/compat/twentyfourteen.css?ver=3.6' type='text/css' media='all' />
<link rel='stylesheet' id='advpsStyleSheet-css'  href='http://ramblernewspapers.com/wp-content/plugins/advanced-post-slider/advps-style.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='twentyfourteen-lato-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900%2C300italic%2C400italic%2C700italic&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='genericons-css'  href='http://ramblernewspapers.com/wp-content/plugins/jetpack/_inc/genericons/genericons/genericons.css?ver=3.1' type='text/css' media='all' />
<link rel='stylesheet' id='twentyfourteen-style-css'  href='http://ramblernewspapers.com/wp-content/themes/twentyfourteen/style.css?ver=4.8' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='twentyfourteen-ie-css'  href='http://ramblernewspapers.com/wp-content/themes/twentyfourteen/css/ie.css?ver=20131205' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='pptwj-widget-tab-css-css'  href='http://ramblernewspapers.com/wp-content/plugins/popular-posts-tab-widget-for-jetpack/tab.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='wptt_front-css'  href='http://ramblernewspapers.com/wp-content/plugins/wp-twitter-feeds/css/admin_style.min.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_image_widget-css'  href='http://ramblernewspapers.com/wp-content/plugins/jetpack/modules/widgets/image-widget/style.css?ver=20140808' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_social_media_icons_widget-css'  href='http://ramblernewspapers.com/wp-content/plugins/jetpack/modules/widgets/social-media-icons/style.css?ver=20150602' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack-top-posts-widget-css'  href='http://ramblernewspapers.com/wp-content/plugins/jetpack/modules/widgets/top-posts/style.css?ver=20141013' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://ramblernewspapers.com/wp-content/plugins/jetpack/css/jetpack.css?ver=3.6' type='text/css' media='all' />
			<script lang="JavaScript">
				//should be over http
				if (window.location.protocol != "http:")
					window.location.href = "http:" + window.location.href.substring(window.location.protocol.length);
			</script>
		<script type='text/javascript' src='http://ramblernewspapers.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://cdn.embedly.com/widgets/platform.js?ver=4.8'></script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-content/plugins/advanced-post-slider/js/advps.frnt.script.js?ver=4.8'></script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-content/plugins/advanced-post-slider/bxslider/jquery.bxslider.min.js?ver=4.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var PPTWJ = {"ajaxUrl":"http:\/\/ramblernewspapers.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-content/plugins/popular-posts-tab-widget-for-jetpack/tab.js?ver=4.8'></script>
<link rel='https://api.w.org/' href='http://ramblernewspapers.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://ramblernewspapers.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://ramblernewspapers.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Rambler 07-22-2017' href='http://ramblernewspapers.com/2017/07/rambler-07-22-2017/' />
<meta name="generator" content="WordPress 4.8" />
<link rel="canonical" href="http://ramblernewspapers.com/2017/07/mark-your-calendar-6/" />
<link rel='shortlink' href='http://wp.me/p3vbfn-4Fq' />
<link rel="alternate" type="application/json+oembed" href="http://ramblernewspapers.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Framblernewspapers.com%2F2017%2F07%2Fmark-your-calendar-6%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://ramblernewspapers.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Framblernewspapers.com%2F2017%2F07%2Fmark-your-calendar-6%2F&#038;format=xml" />
<!-- <meta name="NextGEN" version="2.1.62" /> -->
	<style type="text/css" id="twentyfourteen-header-css">
			.site-title,
		.site-description {
			clip: rect(1px 1px 1px 1px); /* IE7 */
			clip: rect(1px, 1px, 1px, 1px);
			position: absolute;
		}
		</style>
	<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
<meta property="og:type" content="article">
<meta property="og:locale" content="en_US">
<meta property="fb:app_id" content="477513062334887">
<meta property="og:url" content="http://ramblernewspapers.com/2017/07/mark-your-calendar-6/">
<meta property="og:title" content="Mark your calendar!">
<meta property="og:description" content="Blood Donation July 30, 8 a.m. - 2 p.m. Thousands of people have responded to the emergency call for blood donations issued by the American Red Cross in early July, but there continues to be a critical summer blood shortage. Eligible donors of all types are urgently needed. After issuing the emergency call, the Red&hellip;">
<meta property="og:image" content="http://ramblernewspapers.com/wp-content/uploads/2017/07/Blood-Drive-online-edited-2.jpg">
<meta property="og:image:width" content="1020">
<meta property="og:image:height" content="680">
<meta property="og:image" content="http://ramblernewspapers.com/wp-content/uploads/2017/07/Blood-Drive-online-edited.jpg">
<meta property="article:published_time" content="2017-07-28T14:46:53+00:00">
<meta property="article:modified_time" content="2017-07-28T14:47:22+00:00">
<meta property="article:author" content="http://ramblernewspapers.com/author/john-starkey/">
<meta property="article:section" content="Arts &amp; Entertainment">
<meta property="article:tag" content="Community Events">
<meta property="article:tag" content="Coppell">
<meta property="article:tag" content="Featured Stories">
<meta property="article:tag" content="Irving">
		<style type="text/css" id="wp-custom-css">
			add_filter ('the_content', 'wpsites_limit_content_conditionally'); function wpsites_limit_content_conditionally($content) {return substr($content, 0, 100);} return $content; 
		</style>
	<link rel='stylesheet' id='embedly_font_end-css'  href='http://ramblernewspapers.com/wp-content/plugins/embedly/css/embedly-frontend.css?ver=4.8' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelement-css'  href='http://ramblernewspapers.com/wp-includes/js/mediaelement/mediaelementplayer.min.css?ver=2.22.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='http://ramblernewspapers.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=4.8' type='text/css' media='all' />
</head>

<body class="post-template-default single single-post postid-17944 single-format-standard custom-background pmpro-body-has-access group-blog masthead-fixed footer-widgets singular">
<div id="page" class="hfeed site">
	
	<header id="masthead" class="site-header" role="banner">
		<div class="header-main">
			<h1 class="site-title"><a href="http://ramblernewspapers.com/" rel="home"></a></h1>

			<div class="search-toggle">
				<a href="#search-container" class="screen-reader-text" aria-expanded="false" aria-controls="search-container">Search</a>
			</div>

			<nav id="primary-navigation" class="site-navigation primary-navigation" role="navigation">
				<button class="menu-toggle">Primary Menu</button>
				<a class="screen-reader-text skip-link" href="#content">Skip to content</a>
				<div class="menu-top-navigation-container"><ul id="primary-menu" class="nav-menu"><li id="menu-item-25" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-25"><a href="http://ramblernewspapers.com/category/news/">News</a>
<ul  class="sub-menu">
	<li id="menu-item-23" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-23"><a href="http://ramblernewspapers.com/category/irving/">Irving</a></li>
	<li id="menu-item-8792" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8792"><a href="http://ramblernewspapers.com/category/news/contributed/">Contributed</a></li>
	<li id="menu-item-22" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-22"><a href="http://ramblernewspapers.com/category/coppell/">Coppell</a></li>
	<li id="menu-item-1028" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1028"><a href="http://ramblernewspapers.com/category/news/dfw-international/">DFW Area Aviation</a></li>
	<li id="menu-item-17782" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17782"><a href="http://ramblernewspapers.com/category/obituaries/">Obituaries</a></li>
</ul>
</li>
<li id="menu-item-1535" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1535"><a href="http://ramblernewspapers.com/category/local/community-events/">Community Events</a></li>
<li id="menu-item-11486" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-11486"><a href="http://ramblernewspapers.com/category/arts-entertainment/">Arts &#038; Entertainment</a></li>
<li id="menu-item-29" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-29"><a href="http://ramblernewspapers.com/category/sports/">Sports</a></li>
<li id="menu-item-13655" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-13655"><a href="http://ramblernewspapers.com/category/home-health/">Home &#038; Health</a></li>
<li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35"><a href="http://ramblernewspapers.com/category/opinion/letters-to-the-editor/">Letters to the Editor</a></li>
<li id="menu-item-4298" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-4298"><a href="http://ramblernewspapers.com/category/newspaper-archives/">Archives</a>
<ul  class="sub-menu">
	<li id="menu-item-16496" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16496"><a href="http://ramblernewspapers.com/category/newspaper-archives/2017/">2017</a></li>
	<li id="menu-item-14071" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14071"><a href="http://ramblernewspapers.com/category/newspaper-archives/2016/">2016</a></li>
	<li id="menu-item-11312" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11312"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2015/">2015</a></li>
	<li id="menu-item-5062" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5062"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2014-irving-rambler-archive/">2014</a></li>
	<li id="menu-item-4307" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4307"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2013-irving-rambler-archive/">2013</a></li>
	<li id="menu-item-4306" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4306"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2012-irving-rambler-archive/">2012</a></li>
	<li id="menu-item-4324" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4324"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2011/">2011</a></li>
	<li id="menu-item-4323" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4323"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2010/">2010</a></li>
	<li id="menu-item-4322" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4322"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2009/">2009</a></li>
	<li id="menu-item-4321" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4321"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2008/">2008</a></li>
	<li id="menu-item-4320" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4320"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2007/">2007</a></li>
	<li id="menu-item-4319" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4319"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2006/">2006</a></li>
	<li id="menu-item-4318" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4318"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2005/">2005</a></li>
	<li id="menu-item-4317" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4317"><a href="http://ramblernewspapers.com/category/newspaper-archives/irving-rambler-archive/2004/">2004</a></li>
</ul>
</li>
<li id="menu-item-7844" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7844"><a href="http://ramblernewspapers.com/contact/">Contact</a></li>
<li id="menu-item-17860" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-17860"><a href="http://ramblernewspapers.com/subscribe/">Subscribe</a></li>
</ul></div>			</nav>
		</div>

		<div id="search-container" class="search-box-wrapper hide">
			<div class="search-box">
				<form role="search" method="get" class="search-form" action="http://ramblernewspapers.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>			</div>
		</div>
	</header><!-- #masthead -->

	<div id="main" class="site-main">

	<div id="primary" class="content-area">
		<div id="content" class="site-content" role="main">
			
<article id="post-17944" class="post-17944 post type-post status-publish format-standard has-post-thumbnail hentry category-arts-entertainment category-community-events category-coppell category-featured-stories category-irving pmpro-has-access">
	
	<div class="post-thumbnail">
	<img width="672" height="372" src="http://ramblernewspapers.com/wp-content/uploads/2017/07/Blood-Drive-online-edited-2-672x372.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="" />	</div>

	
	<header class="entry-header">
				<div class="entry-meta">
			<span class="cat-links"><a href="http://ramblernewspapers.com/category/arts-entertainment/" rel="category tag">Arts &amp; Entertainment</a>, <a href="http://ramblernewspapers.com/category/local/community-events/" rel="category tag">Community Events</a>, <a href="http://ramblernewspapers.com/category/coppell/" rel="category tag">Coppell</a>, <a href="http://ramblernewspapers.com/category/news/featured-stories/" rel="category tag">Featured Stories</a>, <a href="http://ramblernewspapers.com/category/irving/" rel="category tag">Irving</a></span>
		</div>
		<h1 class="entry-title">Mark your calendar!</h1>
		<div class="entry-meta">
			<span class="entry-date"><a href="http://ramblernewspapers.com/2017/07/mark-your-calendar-6/" rel="bookmark"><time class="entry-date" datetime="2017-07-28T09:46:53+00:00">July 28, 2017</time></a></span> <span class="byline"><span class="author vcard"><a class="url fn n" href="http://ramblernewspapers.com/author/john-starkey/" rel="author">John Starkey</a></span></span>			<span class="comments-link"><a href="http://ramblernewspapers.com/2017/07/mark-your-calendar-6/#respond"><fb:comments-count xmlns="http://ogp.me/ns/fb#" href="http://ramblernewspapers.com/2017/07/mark-your-calendar-6/"></fb:comments-count> Comments</a></span>
					</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

		<div class="entry-content">
		<p><strong>Blood Donation<br />
</strong><strong>July 30, 8 a.m. &#8211; 2 p.m.</strong></p>
<p>Thousands of people have responded to the emergency call for blood donations issued by the American Red Cross in early July, but there continues to be a critical summer blood shortage. Eligible donors of all types are urgently needed.</p>
<p>After issuing the emergency call, the Red Cross has experienced a 30 percent increase in blood donation appointments through mid-July. Despite this improvement, blood products are still being distributed to hospitals as fast as donations are coming in, so more donations are needed to meet patient needs and replenish the blood supply.</p>
<p>A blood donation drive will be held at Holy Family of Nazareth Catholic Parish, 2323 Cheyenne Street, Irving.</p>
<hr>
<p><strong>Free&nbsp;Genealogy&nbsp;Classes</strong><br />
<strong>August 4 – 18, 12:30&nbsp;p.m.</strong>&nbsp;</p>
<p>Free&nbsp;genealogy&nbsp;classes&nbsp;are&nbsp;available&nbsp;to&nbsp;the&nbsp;public&nbsp;provided&nbsp;by&nbsp;The Church&nbsp;of&nbsp;Jesus&nbsp;Christ of Latterday Saints, who has created the largest collection of family records in&nbsp;the&nbsp;world. A&nbsp;three part course will be offered at The Summit Active Adult Center in Grand Prairie.</p>
<p>Topics that will be covered include Genealogy for Beginners, Sources&nbsp;for&nbsp;Genealogical&nbsp;Information&nbsp;and&nbsp;Search Techniques for Genealogical Information. Instructors for the course are Elder and Sister&nbsp;Grieve, missionaries for The Church of Jesus Christ of Latter‐day&nbsp;Saints.</p>
<p>Classes&nbsp;will&nbsp;be&nbsp;Fridays&nbsp;at&nbsp;12:30&nbsp;pm.&nbsp;The&nbsp;class&nbsp;is free for all Summit members. Nonmembers may be charged a $5 entrance fee by The Summit.</p>
<p>The&nbsp;Church&nbsp;of&nbsp;Jesus&nbsp;Christ&nbsp;of&nbsp;Latterday&nbsp;Saints&nbsp;collection&nbsp;of&nbsp;family&nbsp;records&nbsp;includes&nbsp;more&nbsp;than&nbsp;3&nbsp;billion deceased people and has 5,003 family history centers&nbsp;in&nbsp;138&nbsp;countries.</p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow" data-shared="sharing-facebook-17944" class="share-facebook sd-button share-icon" href="http://ramblernewspapers.com/2017/07/mark-your-calendar-6/?share=facebook" target="_blank" title="Share on Facebook"><span>Facebook</span></a></li><li class="share-email"><a rel="nofollow" data-shared="" class="share-email sd-button share-icon" href="http://ramblernewspapers.com/2017/07/mark-your-calendar-6/?share=email" target="_blank" title="Click to email this to a friend"><span>Email</span></a></li><li class="share-print"><a rel="nofollow" data-shared="" class="share-print sd-button share-icon" href="http://ramblernewspapers.com/2017/07/mark-your-calendar-6/#print" target="_blank" title="Click to print"><span>Print</span></a></li><li class="share-end"></li></ul></div></div></div>	</div><!-- .entry-content -->
	
	</article><!-- #post-## -->
	<nav class="navigation post-navigation" role="navigation">
		<h1 class="screen-reader-text">Post navigation</h1>
		<div class="nav-links">
			<a href="http://ramblernewspapers.com/2017/07/rambler-07-22-2017/" rel="prev"><span class="meta-nav">Previous Post</span>Rambler 07-22-2017</a>		</div><!-- .nav-links -->
	</nav><!-- .navigation -->
	
<div id="comments" class="comments-area">
<div id="respond" class="comment-respond">
<div class="fb-social-plugin comment-form fb-comments" id="commentform" data-href="http://ramblernewspapers.com/2017/07/mark-your-calendar-6/" data-width="462" data-order-by="social"></div>
</div></div>
		</div><!-- #content -->
	</div><!-- #primary -->

<div id="content-sidebar" class="content-sidebar widget-area" role="complementary">
	<aside id="media_video-3" class="widget widget_media_video"><h1 class="widget-title">Videos</h1><div style="width:100%;" class="wp-video"><!--[if lt IE 9]><script>document.createElement('video');</script><![endif]-->
<video class="wp-video-shortcode" id="video-17944-1" preload="metadata" controls="controls"><source type="video/youtube" src="https://www.youtube.com/watch?v=7PqKP5lI-sA&#038;loop=0&#038;_=1" /><a href="https://www.youtube.com/watch?v=7PqKP5lI-sA&#038;loop=0">https://www.youtube.com/watch?v=7PqKP5lI-sA&#038;loop=0</a></video></div></aside><aside id="media_video-4" class="widget widget_media_video"><div style="width:100%;" class="wp-video"><video class="wp-video-shortcode" id="video-17944-2" preload="metadata" controls="controls"><source type="video/youtube" src="https://www.youtube.com/watch?v=WjTrwOMRHFg&#038;loop=0&#038;_=2" /><a href="https://www.youtube.com/watch?v=WjTrwOMRHFg&#038;loop=0">https://www.youtube.com/watch?v=WjTrwOMRHFg&#038;loop=0</a></video></div></aside><aside id="media_video-5" class="widget widget_media_video"><div style="width:100%;" class="wp-video"><video class="wp-video-shortcode" id="video-17944-3" preload="metadata" controls="controls"><source type="video/youtube" src="https://www.youtube.com/watch?v=xi_QhXYyRYM&#038;loop=0&#038;_=3" /><a href="https://www.youtube.com/watch?v=xi_QhXYyRYM&#038;loop=0">https://www.youtube.com/watch?v=xi_QhXYyRYM&#038;loop=0</a></video></div></aside><aside id="image-7" class="widget widget_image"><div class="jetpack-image-container"><a href="http://www.christianscienceirving.com/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/FCCSedit2.jpg" class="alignnone" width="640" height="272" /></a></div>
</aside><aside id="image-2" class="widget widget_image"><div class="jetpack-image-container"><a href="http://www.chateauonwildbriarlake.com/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/5191-800x450.jpg" class="aligncenter" width="431" height="604" /></a></div>
</aside><aside id="image-9" class="widget widget_image"><div class="jetpack-image-container"><a href="https://www.facebook.com/Betcha-Bingo-813975168680884/?rf=188739101162941"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/BETCHA-LOGO-1024x87.jpg" class="alignnone" /></a></div>
</aside><aside id="wptt_twittertweets-2" class="widget wptt_TwitterTweets"><h1 class="widget-title">Latest Tweets</h1>			

<ul class="fetched_tweets light">
						    			        <li class="tweets_avatar">
			        	<div class="tweet_wrap"><div class="wdtf-user-card ltr"><div class="clear"></div></div>			       		<div class="tweet_data">
			        	Banks want to start making payday loans again | <a href="https://t.co/WwC6Ct0gs2" target="_blank" rel="nofollow">https://t.co/WwC6Ct0gs2</a> <a href="https://t.co/rgQQthbhBC" target="_blank" rel="nofollow">https://t.co/rgQQthbhBC</a>			        	</div>
			            <br/>
			            <div class="clear"></div>
			            <div class="times">
			            <em>
			            
						<a href="http://www.twitter.com/DFW_Rambler" target="_blank" title="Follow Rambler Newspapers on Twitter [Opens new window]">
							7d							</a>
			            </em>
			            </div>
												<div class="clear"></div>
</div><div class="clear"></div>
			        </li>
			    
						</ul>
			
			</aside><aside id="image-5" class="widget widget_image"><div class="jetpack-image-container"><a href="http://www.unitychurchofirving.com/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/5185.png" class="alignnone" width="1024" height="512" /></a></div>
</aside>	
			<aside id="pptwj-2" class="widget pptwj">
			
			<div class="pptwj-tabs-wrap">
	
				<ul class="tab-links">
										
					<li class="popular"><a href="#tab-pop">Popular</a></li>										<li class="latest"><a href="#tab-latest">Latest</a></li>				</ul>
				
				<div class="clear"></div>
	
				<div class="boxes box inside">
	
						
										<div id="tab-pop">
						<ul class="tab-filter-list" data-type="popular">
							<li>
																	<a href="#" data-time="day" data-numberposts="10" data-thumb="3" data-tab="popular">Today</a>
																	<a href="#" data-time="week" data-numberposts="10" data-thumb="3" data-tab="popular">Week</a>
																	<a href="#" data-time="month" data-numberposts="10" data-thumb="3" data-tab="popular">Month</a>
																	<a href="#" data-time="all" data-numberposts="10" data-thumb="3" data-tab="popular">All</a>
															</li>
						</ul>
						<ul class="list">
									<li class="odd">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/07/blaze-burns-through-warehouse/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/07/Firefighter-online-edited-150x100.jpg" alt="Blaze burns through warehouse" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Blaze burns through warehouse" href="http://ramblernewspapers.com/2017/07/blaze-burns-through-warehouse/">Blaze burns through warehouse</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="even">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/07/kona-ice-now-serving-irving/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/07/Kona-Ice-edited-2-150x100.jpg" alt="Kona Ice now serving Irving" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Kona Ice now serving Irving" href="http://ramblernewspapers.com/2017/07/kona-ice-now-serving-irving/">Kona Ice now serving Irving</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="odd">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/07/irving-police-department-honored-with-barbeque/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/07/Police-BBQ-2-online-edited-150x101.jpg" alt="Irving police department honored with barbeque" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Irving police department honored with barbeque" href="http://ramblernewspapers.com/2017/07/irving-police-department-honored-with-barbeque/">Irving police department honored with barbeque</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="even">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/07/rambler-07-08-2017/"><img src="http://ramblernewspapers.com/wp-content/plugins/popular-posts-tab-widget-for-jetpack/default.png" alt="Rambler 07-08-2017" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Rambler 07-08-2017" href="http://ramblernewspapers.com/2017/07/rambler-07-08-2017/">Rambler 07-08-2017</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="odd">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/07/young-men-graduate-high-school-with-a-little-help/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/07/La-Buena-Vida-Photo-online-edited-3-150x90.jpg" alt="Young men graduate high school with a little help" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Young men graduate high school with a little help" href="http://ramblernewspapers.com/2017/07/young-men-graduate-high-school-with-a-little-help/">Young men graduate high school with a little help</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="even">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/07/rambler-07-01-2017/"><img src="http://ramblernewspapers.com/wp-content/plugins/popular-posts-tab-widget-for-jetpack/default.png" alt="Rambler 07-01-2017" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Rambler 07-01-2017" href="http://ramblernewspapers.com/2017/07/rambler-07-01-2017/">Rambler 07-01-2017</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="odd">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/07/texas-workforce-commission-updates-businesses-on-employment-laws/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/07/Texas-Workforce-Commission-online-edited-150x79.jpg" alt="Texas Workforce Commission updates businesses on employment laws" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Texas Workforce Commission updates businesses on employment laws" href="http://ramblernewspapers.com/2017/07/texas-workforce-commission-updates-businesses-on-employment-laws/">Texas Workforce Commission updates businesses on employment laws</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="even">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/06/challenge-air-hands-controls-to-youngsters-with-special-needs/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/06/Challenge-Air-1-online-edited-4-150x106.jpg" alt="Challenge Air hands controls to youngsters with special needs" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Challenge Air hands controls to youngsters with special needs" href="http://ramblernewspapers.com/2017/06/challenge-air-hands-controls-to-youngsters-with-special-needs/">Challenge Air hands controls to youngsters with special needs</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="odd">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/07/landfill-urges-residents-to-recycle/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/07/Landfill-online-edited-150x100.png" alt="Landfill urges residents to recycle" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Landfill urges residents to recycle" href="http://ramblernewspapers.com/2017/07/landfill-urges-residents-to-recycle/">Landfill urges residents to recycle</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
				<li class="even">
										<a class="post-thumb" href="http://ramblernewspapers.com/2017/07/obituary-jane-marlow-easter/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/07/Jane-Easter-online-edited.jpg" alt="Jane Marlow Easter" width="3" height="3" style="width: 3px; height: 3px;"/></a>
						<a class="item-title" title="Jane Marlow Easter" href="http://ramblernewspapers.com/2017/07/obituary-jane-marlow-easter/">Jane Marlow Easter</a>
			<span class="meta"></span>			<div class="fix"></div>
		</li>
								</ul>
					</div><!-- #tab-pop -->
															<div id="tab-latest">
						<ul class="list">
										<li class="odd">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/07/mark-your-calendar-6/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/07/Blood-Drive-online-edited-2-150x100.jpg" alt="Mark your calendar!" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Mark your calendar!" href="http://ramblernewspapers.com/2017/07/mark-your-calendar-6/">Mark your calendar!</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="even">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/07/rambler-07-22-2017/"><img src="http://ramblernewspapers.com/wp-content/plugins/popular-posts-tab-widget-for-jetpack/default.png" alt="Rambler 07-22-2017" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Rambler 07-22-2017" href="http://ramblernewspapers.com/2017/07/rambler-07-22-2017/">Rambler 07-22-2017</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="odd">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/07/rambler-07-15-2017/"><img src="http://ramblernewspapers.com/wp-content/plugins/popular-posts-tab-widget-for-jetpack/default.png" alt="Rambler 07-15-2017" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Rambler 07-15-2017" href="http://ramblernewspapers.com/2017/07/rambler-07-15-2017/">Rambler 07-15-2017</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="even">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/07/banks-want-to-start-making-payday-loans-again/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/07/Payday-loans-online-edited-150x157.png" alt="Banks want to start making payday loans again" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Banks want to start making payday loans again" href="http://ramblernewspapers.com/2017/07/banks-want-to-start-making-payday-loans-again/">Banks want to start making payday loans again</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="odd">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/07/landfill-urges-residents-to-recycle/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/07/Landfill-online-edited-150x100.png" alt="Landfill urges residents to recycle" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Landfill urges residents to recycle" href="http://ramblernewspapers.com/2017/07/landfill-urges-residents-to-recycle/">Landfill urges residents to recycle</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="even">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/07/city-officials-seek-community-input-in-dart-fare-restructure/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/07/DART-edited-online-150x101.png" alt="City officials seek community input in DART fare restructure" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="City officials seek community input in DART fare restructure" href="http://ramblernewspapers.com/2017/07/city-officials-seek-community-input-in-dart-fare-restructure/">City officials seek community input in DART fare restructure</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="odd">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/07/blaze-burns-through-warehouse/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/07/Firefighter-online-edited-150x100.jpg" alt="Blaze burns through warehouse" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Blaze burns through warehouse" href="http://ramblernewspapers.com/2017/07/blaze-burns-through-warehouse/">Blaze burns through warehouse</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="even">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/07/texas-workforce-commission-updates-businesses-on-employment-laws/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/07/Texas-Workforce-Commission-online-edited-150x79.jpg" alt="Texas Workforce Commission updates businesses on employment laws" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Texas Workforce Commission updates businesses on employment laws" href="http://ramblernewspapers.com/2017/07/texas-workforce-commission-updates-businesses-on-employment-laws/">Texas Workforce Commission updates businesses on employment laws</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="odd">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/07/non-profits-join-forces-for-irving-kids-charity-golf-classic/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/07/Irving-Kids-Golf-Classic-edited-2-150x100.jpg" alt="Non-profits join forces for Irving Kids Charity Golf Classic" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Non-profits join forces for Irving Kids Charity Golf Classic" href="http://ramblernewspapers.com/2017/07/non-profits-join-forces-for-irving-kids-charity-golf-classic/">Non-profits join forces for Irving Kids Charity Golf Classic</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
					<li class="even">
												<a class="post-thumb" href="http://ramblernewspapers.com/2017/07/young-men-graduate-high-school-with-a-little-help/"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/07/La-Buena-Vida-Photo-online-edited-3-150x90.jpg" alt="Young men graduate high school with a little help" width="3" height="3" style="width: 3px; height: 3px;"/></a>
								
				<a class="item-title" title="Young men graduate high school with a little help" href="http://ramblernewspapers.com/2017/07/young-men-graduate-high-school-with-a-little-help/">Young men graduate high school with a little help</a>

				<span class="meta"></span>
				<div class="fix"></div>
			</li>
								</ul>
					</div><!-- #tab-latest -->
															<div class="pptwj-loader"><img src="http://ramblernewspapers.com/wp-includes//images/wpspin-2x.gif" alt="Ajax spinner"></div>
				</div><!-- /.boxes -->
			</div><!-- /pptwj-tabs-wrap -->

			</aside>			<aside id="image-3" class="widget widget_image"><div class="jetpack-image-container"><a href="https://www.statefarm.com/agent/US/TX/Irving/Bill-Hooten-4XDNY1YS000"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/Hooten-High-Quality-1024x170.jpg" class="alignnone" width="1024" height="170" /></a></div>
</aside><aside id="image-13" class="widget widget_image"><div class="jetpack-image-container"><a href="http://www.beltlinechurch.com/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/5227-800x188.jpg" class="alignnone" /></a></div>
</aside><aside id="image-4" class="widget widget_image"><div class="jetpack-image-container"><a href="http://verde.tech/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/verdelogo-2-800x196.jpg" class="alignnone" width="800" height="196" /></a></div>
</aside></div><!-- #content-sidebar -->
<div id="secondary">
		<h2 class="site-description">Serving Irving, Las Colinas, Valley Ranch, Coppell and DFW International Airport</h2>
	
	
		<div id="primary-sidebar" class="primary-sidebar widget-area" role="complementary">
		<aside id="image-16" class="widget widget_image"><div class="jetpack-image-container"><figure style="width: 1107px" class="wp-caption alignleft"><a href="http://www.ramblernewspapers.com"><img src="http://ramblernewspapers.com/wp-content/uploads/2017/07/Rambler-Newspapers-4-blackish-background-png.png" width="1107" height="431" /></a><figcaption class="wp-caption-text">Serving Irving, Las Colinas, Valley Ranch, Coppell, and DFW International Airport</figcaption></figure></div>
</aside><aside id="wpcom_social_media_icons_widget-2" class="widget widget_wpcom_social_media_icons_widget"><ul><li><a title="View @RamblerNewspapers&#8217;s profile on Facebook" href="https://www.facebook.com/@RamblerNewspapers/" class="genericon genericon-facebook" target="_blank"><span class="screen-reader-text">View @RamblerNewspapers&#8217;s profile on Facebook</span></a></li><li><a title="View @DFW_Rambler&#8217;s profile on Twitter" href="https://twitter.com/@DFW_Rambler/" class="genericon genericon-twitter" target="_blank"><span class="screen-reader-text">View @DFW_Rambler&#8217;s profile on Twitter</span></a></li><li><a title="View ramblernewspapers&#8217;s profile on Instagram" href="https://instagram.com/ramblernewspapers/" class="genericon genericon-instagram" target="_blank"><span class="screen-reader-text">View ramblernewspapers&#8217;s profile on Instagram</span></a></li><li><a title="View UCjQcrxhghB8NdAGYYQe4rJQ&#8217;s profile on YouTube" href="https://www.youtube.com/channel/UCjQcrxhghB8NdAGYYQe4rJQ" class="genericon genericon-youtube" target="_blank"><span class="screen-reader-text">View UCjQcrxhghB8NdAGYYQe4rJQ&#8217;s profile on YouTube</span></a></li></ul></aside><aside id="media_image-2" class="widget widget_media_image"><h1 class="widget-title">Irving History in Pictures</h1><figure style="width: 300px" class="wp-caption alignnone"><img width="300" height="210" src="http://ramblernewspapers.com/wp-content/uploads/2017/07/1924-Irving-High-School-football-team-district-champs-editedb-300x210.jpg" class="image wp-image-17826  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="http://ramblernewspapers.com/wp-content/uploads/2017/07/1924-Irving-High-School-football-team-district-champs-editedb-300x210.jpg 300w, http://ramblernewspapers.com/wp-content/uploads/2017/07/1924-Irving-High-School-football-team-district-champs-editedb-150x105.jpg 150w, http://ramblernewspapers.com/wp-content/uploads/2017/07/1924-Irving-High-School-football-team-district-champs-editedb-768x537.jpg 768w, http://ramblernewspapers.com/wp-content/uploads/2017/07/1924-Irving-High-School-football-team-district-champs-editedb-1024x716.jpg 1024w, http://ramblernewspapers.com/wp-content/uploads/2017/07/1924-Irving-High-School-football-team-district-champs-editedb-900x629.jpg 900w, http://ramblernewspapers.com/wp-content/uploads/2017/07/1924-Irving-High-School-football-team-district-champs-editedb.jpg 1457w" sizes="(max-width: 300px) 100vw, 300px" /><figcaption class="wp-caption-text">Irving High School football team, 1924 district champs</figcaption></figure></aside><aside id="top-posts-2" class="widget widget_top-posts"><h1 class="widget-title">Top Stories</h1><ul>				<li>
										<a href="http://ramblernewspapers.com/2017/05/irving-hosts-jrotc-national-drill-championship/" class="bump-view" data-bump-view="tp">
						Irving hosts JROTC National Drill Championship					</a>
									</li>
							<li>
										<a href="http://ramblernewspapers.com/2017/07/texas-workforce-commission-updates-businesses-on-employment-laws/" class="bump-view" data-bump-view="tp">
						Texas Workforce Commission updates businesses on employment laws					</a>
									</li>
							<li>
										<a href="http://ramblernewspapers.com/2017/07/landfill-urges-residents-to-recycle/" class="bump-view" data-bump-view="tp">
						Landfill urges residents to recycle					</a>
									</li>
							<li>
										<a href="http://ramblernewspapers.com/2017/07/rambler-07-22-2017/" class="bump-view" data-bump-view="tp">
						Rambler 07-22-2017					</a>
									</li>
			</ul></aside><aside id="blog_subscription-2" class="widget jetpack_subscription_widget"><h1 class="widget-title">Subscribe to Rambler Newspapers via Email</h1>
			<form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-2">
				<div id="subscribe-text"><p>Enter your email address to subscribe to Rambler Newspapers and receive notifications of new posts by email.</p>
</div>					<p id="subscribe-email">
						<label id="jetpack-subscribe-label" for="subscribe-field">
							Email Address						</label>
						<input type="email" name="email" required="required" class="required" value="" id="subscribe-field" placeholder="Email Address" />
					</p>

					<p id="subscribe-submit">
						<input type="hidden" name="action" value="subscribe" />
						<input type="hidden" name="source" value="http://ramblernewspapers.com/2017/07/mark-your-calendar-6/" />
						<input type="hidden" name="sub-type" value="widget" />
						<input type="hidden" name="redirect_fragment" value="blog_subscription-2" />
												<input type="submit" value="Subscribe" name="jetpack_subscriptions_widget" />
					</p>
							</form>

			<script>
			(function( d ) {
				if ( ( 'placeholder' in d.createElement( 'input' ) ) ) {
					var label = d.getElementById( 'jetpack-subscribe-label' );
						label.style.clip 	 = 'rect(1px, 1px, 1px, 1px)';
						label.style.position = 'absolute';
						label.style.height   = '1px';
						label.style.width    = '1px';
						label.style.overflow = 'hidden';
				}
			
				var form = d.getElementById('subscribe-blog-blog_subscription-2'), 
					input = d.getElementById('subscribe-field'),
					handler = function( event ) {
						if ( '' === input.value ) {
							input.focus();
							
							if ( event.preventDefault ){
								event.preventDefault();
							}
							
							return false; 
						}
					}; 
			
				if ( window.addEventListener ) {
					form.addEventListener( 'submit', handler, false );
				} else {
					form.attachEvent( 'onsubmit', handler );
				}
			})( document );
			</script>
				
</aside><aside id="image-12" class="widget widget_image"><div class="jetpack-image-container"><a href="https://www.ppumc.org/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/ppumc-609x324.jpg" class="alignnone" /></a></div>
</aside><aside id="image-6" class="widget widget_image"><div class="jetpack-image-container"><a href="http://irvinghcc.com/home/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/Logo-Color-horse-for-chamber-Copy-1024x512.jpg" class="alignnone" /></a></div>
</aside><aside id="image-11" class="widget widget_image"><div class="jetpack-image-container"><a href="https://www.expresspros.com/IrvingTX/"><img src="http://ramblernewspapers.com/wp-content/uploads/2016/11/exp-emp-1024x320.jpg" class="alignnone" /></a></div>
</aside>
<!-- Start - HTML Javascript Adder plugin v3.9 -->
<aside id="html_javascript_adder-4" class="widget widget_html_javascript_adder">
<div class="hjawidget textwidget">
<!-- Beginning PassBack for Ad unit BENN/Irving_Rambler ### size: [[160,600]] -->
<script type='text/javascript' src='http://www.googletagservices.com/tag/js/gpt.js'>
googletag.pubads().definePassback('6785150/BENN/Irving_Rambler', [[160,600]]).setTargeting('fold',['ATF']).display();
</script>
<!-- End Passback -->
</div>
</aside><!-- End - HTML Javascript Adder plugin v3.9 -->
<aside id="text-5" class="widget widget_text"><h1 class="widget-title">Sponsor Rambler&#8217;s Irving Historical Series</h1>			<div class="textwidget"><p>Rambler Newspapers is starting a four-week historical series to run in the paper and online! Through old photos and stories, we will draft the history of Irving starting in the early 1900s to present day.</p>
<p>To launch the series, we are looking for individuals as well as businesses/organizations that can act as</p>
<div class="text_exposed_show">
<p>We believe this is an important series to inform our readers about the city&#8217;s rich history and your sponsorship can help bring this series to life.</p>
<p>Please call Rambler Newspapers at (972) 870-1992 or email JoeS@ramblernewspapers.net to become a sponsor today!</p>
</div>
</div>
		</aside><aside id="rss-2" class="widget widget_rss"><h1 class="widget-title"><a class="rsswidget" href="http://www.star-telegram.com/news/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="http://ramblernewspapers.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="http://www.star-telegram.com/news/">Fort Worth Star-Telegram</a></h1><ul><li><a class='rsswidget' href='http://www.star-telegram.com/news/politics-government/national-politics/article164182937.html#storylink=rss'>State workers in Jefferson City get day off for the eclipse</a></li><li><a class='rsswidget' href='http://www.star-telegram.com/news/politics-government/national-politics/article164163152.html#storylink=rss'>AP Exclusive: Disabled Iowa trooper works as security guard</a></li><li><a class='rsswidget' href='http://www.star-telegram.com/news/nation-world/national/article164183002.html#storylink=rss'>No bail reduction in California crash recorded on Instagram</a></li><li><a class='rsswidget' href='http://www.star-telegram.com/news/politics-government/national-politics/article164182612.html#storylink=rss'>Man sentenced to prison for illegal firearm possession</a></li><li><a class='rsswidget' href='http://www.star-telegram.com/news/nation-world/world/article164155022.html#storylink=rss'>Chief prosecutor: At least 113 deaths in Venezuela crisis</a></li></ul></aside>	</div><!-- #primary-sidebar -->
	</div><!-- #secondary -->

		</div><!-- #main -->

		<footer id="colophon" class="site-footer" role="contentinfo">

			
<div id="supplementary">
	<div id="footer-sidebar" class="footer-sidebar widget-area" role="complementary">
		<aside id="nav_menu-2" class="widget widget_nav_menu"><div class="menu-bottom-navigation-container"><ul id="menu-bottom-navigation" class="menu"><li id="menu-item-17" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17"><a href="http://www.ramblernewspapers.com">Home</a></li>
<li id="menu-item-1064" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1064"><a href="http://ramblernewspapers.com/contact/about-rambler-newspapers/">About</a></li>
<li id="menu-item-2287" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2287"><a href="http://ramblernewspapers.com/legal/">Privacy Policy &#038; Terms of Service</a></li>
<li id="menu-item-1063" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1063"><a href="http://ramblernewspapers.com/contact/">Contact</a></li>
<li id="menu-item-1062" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1062"><a href="http://ramblernewspapers.com/subscribe/">Subscribe</a></li>
</ul></div></aside>	</div><!-- #footer-sidebar -->
</div><!-- #supplementary -->

			<div class="site-info">
								<a href="https://wordpress.org/">Proudly powered by WordPress</a>
			</div><!-- .site-info -->
		</footer><!-- #colophon -->
	</div><!-- #page -->

	<!-- ngg_resource_manager_marker -->			<script lang="JavaScript">
				//should be over http
				if (window.location.protocol != "http:")
					window.location.href = "http:" + window.location.href.substring(window.location.protocol.length);
			</script>
		<script type='text/javascript' src='http://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201730'></script>
<script type='text/javascript' src='http://s.gravatar.com/js/gprofiles.js?ver=2017Julaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=4.8'></script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-includes/js/comment-reply.min.js?ver=4.8'></script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-includes/js/jquery/jquery.masonry.min.js?ver=3.1.2b'></script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-content/themes/twentyfourteen/js/functions.js?ver=20150315'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var FB_WP=FB_WP||{};FB_WP.queue={_methods:[],flushed:false,add:function(fn){FB_WP.queue.flushed?fn():FB_WP.queue._methods.push(fn)},flush:function(){for(var fn;fn=FB_WP.queue._methods.shift();){fn()}FB_WP.queue.flushed=true}};window.fbAsyncInit=function(){FB.init({"xfbml":true,"appId":"477513062334887"});if(FB_WP && FB_WP.queue && FB_WP.queue.flush){FB_WP.queue.flush()}}
/* ]]> */
</script>
<script type="text/javascript">(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id)){return}js=d.createElement(s);js.id=id;js.src="http:\/\/connect.facebook.net\/en_US\/all.js";fjs.parentNode.insertBefore(js,fjs)}(document,"script","facebook-jssdk"));</script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-includes/js/wp-embed.min.js?ver=4.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mejsL10n = {"language":"en-US","strings":{"Close":"Close","Fullscreen":"Fullscreen","Turn off Fullscreen":"Turn off Fullscreen","Go Fullscreen":"Go Fullscreen","Download File":"Download File","Download Video":"Download Video","Play":"Play","Pause":"Pause","Captions\/Subtitles":"Captions\/Subtitles","None":"None","Time Slider":"Time Slider","Skip back %1 seconds":"Skip back %1 seconds","Video Player":"Video Player","Audio Player":"Audio Player","Volume Slider":"Volume Slider","Mute Toggle":"Mute Toggle","Unmute":"Unmute","Mute":"Mute","Use Up\/Down Arrow keys to increase or decrease volume.":"Use Up\/Down Arrow keys to increase or decrease volume.","Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds."}};
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/"};
/* ]]> */
</script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=2.22.0'></script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=4.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://ramblernewspapers.com/wp-content/plugins/jetpack/modules/sharedaddy/sharing.js?ver=3.6'></script>
		<!-- Memberships powered by Paid Memberships Pro v1.9.3.
 -->
		<!-- Powered by WPtouch: 3.8.1 -->	<div style="display:none">
	</div>
		<script type="text/javascript">
			!function(d,s,id){
				var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';
				if(!d.getElementById(id)){
					js=d.createElement(s);
					js.id=id;js.src=p+"://platform.twitter.com/widgets.js";
					fjs.parentNode.insertBefore(js,fjs);
				}
			}(document,"script","twitter-wjs");
		</script>
		
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"http:\/\/ramblernewspapers.com\/2017\/07\/mark-your-calendar-6\/":17944};
		window.WPCOM_jetpack = true;
				window.WPCOM_site_ID = 51760413;
			</script>
		<script type="text/javascript">
			var windowOpen;
		jQuery(document).on( 'ready post-load', function(){
			jQuery( 'a.share-facebook' ).on( 'click', function() {
				if ( 'undefined' !== typeof windowOpen ){ // If there's another sharing window open, close it.
					windowOpen.close();
				}
				windowOpen = window.open( jQuery(this).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
		});
		</script>
			<div id="sharing_email" style="display: none;">
		<form action="/2017/07/mark-your-calendar-6/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" />
			<script> document.getElementById('jetpack-source_f_name').value = ''; </script>
			
			<img style="float: right; display: none" class="loading" src="http://ramblernewspapers.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<div id="fb-root"></div><script type='text/javascript' src='http://stats.wp.com/e-201730.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:3.6',blog:'51760413',post:'17944',tz:'-5',srv:'ramblernewspapers.com'} ]);
	_stq.push([ 'clickTrackerInit', '51760413', '17944' ]);
</script>
</body>
</html>